Discussione:
Connessione HTTPS su IIS
(troppo vecchio per rispondere)
Gatsu
2006-02-16 13:47:49 UTC
Permalink
Ciao,

ho IIS su Windows 2000 Server.

Mi è stato chiesto di configurare una connessione HTTPS per uno dei
miei siti.

Qualche dritta su come si fa o dove reperire delle info?

Grazie
JD
Christian Paparelli
2006-02-16 13:57:15 UTC
Permalink
Post by Gatsu
Ciao,
ciao
Post by Gatsu
ho IIS su Windows 2000 Server.
Mi è stato chiesto di configurare una connessione HTTPS per uno dei
miei siti.
Qualche dritta su come si fa o dove reperire delle info?
devi acquistare un certificato digitale da un CA valida e poi installarlo
qui trovi i passi
http://support.microsoft.com/kb/q228991/
--
Christian Paparelli
http://www.ithost.ch
S.NET
2006-02-16 13:58:05 UTC
Permalink
Post by Gatsu
Ciao,
ho IIS su Windows 2000 Server.
Mi è stato chiesto di configurare una connessione HTTPS per uno dei
miei siti.
Qualche dritta su come si fa o dove reperire delle info?
Grazie
JD
http://www.petri.co.il/configure_ssl_on_your_website_with_iis.htm

ricorda che se devi proteggere un sito tipo ecommerce, hai bisogno di un
certificato a pagamento

www.trustitalia.it

ciao
--
S.NET
----------
Premere CTRL+ALT+CANC per riavviare
Edoardo Benussi [MVP]
2006-02-16 14:00:20 UTC
Permalink
Post by Gatsu
Ciao,
ho IIS su Windows 2000 Server.
Mi è stato chiesto di configurare una connessione HTTPS per uno dei
miei siti.
Qualche dritta su come si fa o dove reperire delle info?
http://support.microsoft.com/kb/324069/en-us
--
Edoardo Benussi - ***@mvps.org
Microsoft® MVP - Windows Server
http://mvp.support.microsoft.com
Gatsu
2006-02-21 14:39:21 UTC
Permalink
Per fare dei test c'è modo di creare un certificato senza doverne
scaricare uno in versione trial?

Grazie
JD
Edoardo Benussi [MVP]
2006-02-21 14:51:23 UTC
Permalink
Post by Gatsu
Per fare dei test c'è modo di creare un certificato senza doverne
scaricare uno in versione trial?
non ti puoi mettere in piedi una tua CA ?
--
Edoardo Benussi - ***@mvps.org
Microsoft® MVP - Windows Server
http://mvp.support.microsoft.com
Christian Paparelli
2006-02-21 14:55:49 UTC
Permalink
"Edoardo Benussi [MVP]" <***@tin.it> ha scritto nel messaggio news:%***@TK2MSFTNGP15.phx.gbl...

ciao Edo
Post by Edoardo Benussi [MVP]
non ti puoi mettere in piedi una tua CA ?
aggiungo http://support.microsoft.com/default.aspx?scid=kb;EN-US;q290625

visto che credo di conoscere la prossima domanda :-D
--
Christian Paparelli
http://www.ithost.ch
Edoardo Benussi [MVP]
2006-02-21 15:45:07 UTC
Permalink
Post by Christian Paparelli
visto che credo di conoscere la prossima domanda :-D
non credo!
la prossima è:
chissà cosa ci sarà per cena ?
LOL
--
Edoardo Benussi - ***@mvps.org
Microsoft® MVP - Windows Server
http://mvp.support.microsoft.com
Gatsu
2006-02-21 15:52:39 UTC
Permalink
Post by Christian Paparelli
visto che credo di conoscere la prossima domanda
Ringrazio molto entrambi,
mi ero bloccato alla creazione del file certreq.txt perchè non capivo
(e non capisco) la sezione "Submit a Certificate Request": Come
dovrebbe funzionare questo link: "http://YourWebServerName/certsrv/" ?
Alessandro Borille
2006-02-21 16:04:00 UTC
Permalink
Post by Gatsu
Post by Christian Paparelli
visto che credo di conoscere la prossima domanda
Ringrazio molto entrambi,
mi ero bloccato alla creazione del file certreq.txt perchè non capivo
(e non capisco) la sezione "Submit a Certificate Request": Come
dovrebbe funzionare questo link: "http://YourWebServerName/certsrv/" ?
http://support.microsoft.com/default.aspx?scid=kb;EN-US;323342
Gatsu
2006-02-21 16:49:37 UTC
Permalink
Post by Alessandro Borille
http://support.microsoft.com/default.aspx?scid=kb;EN-US;323342
Ok, ma sono fermo ancora al punto di configurare "Submit a Certificate
Request". Facendo un "cerca" trovo la cartella "certsrv" dentro
c:\winnt\system32\certsrv

Devo far sì che il link http://ipmiowebserver/certsrv punti a quella
cartella?

Grazie
Edoardo Benussi [MVP]
2006-02-21 19:41:06 UTC
Permalink
Post by Gatsu
Post by Alessandro Borille
http://support.microsoft.com/default.aspx?scid=kb;EN-US;323342
Ok, ma sono fermo ancora al punto di configurare "Submit a Certificate
Request". Facendo un "cerca" trovo la cartella "certsrv" dentro
c:\winnt\system32\certsrv
Devo far sì che il link http://ipmiowebserver/certsrv punti a quella
cartella?
quando installi la tua CA
sotto al default web site viene
creata automaticamente la
virtual directory certsrv.
--
Edoardo Benussi - ***@mvps.org
Microsoft® MVP - Windows Server
http://mvp.support.microsoft.com
Gatsu
2006-02-22 11:08:15 UTC
Permalink
Post by Edoardo Benussi [MVP]
quando installi la tua CA
Mi pare d'aver capito che devo andare in "INSTALLAZIONE APPLICAZIONI" e
installare il componente Windows "SERVIZI CERTIFICATI".

Mi chiede se voglio installare una CA GLOBALE (ENTERPRISE, principale o
subordinata; entrambe richiedono Active Directory) o AUTONOMA
(STANDALONE, principale o subordinata) e poi posso selezionare "Opzioni
avanzate".

Dopodichè devo compilare dei dati anagrafici e selezionare la cartella
condivisa dove intendo archiviare le informazioni di configurazione.

Siccome devo installare un certificato come test che opzioni mi
consigliate? Ho Active Directory sul server Web ma se fosse possibile
sceglierei quella meno "invadente", la CA AUTONOMA STANDALONE, sempre
che sia possibile.

Poichè il server Web è una macchina in produzione non vorrei
rischiare di darle dei problemi. So già che alla fine
dell'installazione della CA dovrò restartare IIS.

Grazie
Gatsu
2006-02-23 16:20:13 UTC
Permalink
Mi chiede se...
Nessuna dritta al mio precedente post?
Gatsu
2006-03-03 16:22:50 UTC
Permalink
HTTPS su IIS (Windows 2000 Server, IIS 5)
Ciao,

dopo dai e dai sono riuscito a capirne un pò di + su certificati, CA,
ecc.

Sembra che ora sia tutto configurato correttamente ma se digito
"https://www.dominio.xyz" (o anche "https/www.dominio.xyz:4343") mi
restituisce "Impossibile visualizzare la pagina".

Non ho trovato errori nell'Event Viewer.

Grazie!
Gatsu
2006-03-03 16:34:22 UTC
Permalink
Sembra che...
Ops! Ora funziona! Booohh!!

Il fatto che non mi appare il lucchetto a fondo pagina è perchè sto
usando un certificato di test che ho creato con IIS?
Edoardo Benussi [MVP]
2006-03-03 21:15:22 UTC
Permalink
Post by Gatsu
Il fatto che non mi appare il lucchetto a fondo pagina è perchè sto
usando un certificato di test che ho creato con IIS?
no, c'è qualcosa che non va.
spiegati meglio.
--
Edoardo Benussi - ***@mvps.org
Microsoft® MVP - Windows Server
http://mvp.support.microsoft.com
Gatsu
2006-03-07 14:18:49 UTC
Permalink
Post by Edoardo Benussi [MVP]
no, c'è qualcosa che non va
Ci provo.
Dall'IIS sono entrato nella configurazione del sito XYZ e ho richiesto
il certificato (si è creato il file certreq.txt).
Sono quindi entrato via browser qui: http://ipserverweb/certsrv e ho
caricato il file certreq.txt.
Ho quindi emesso il certificato accedendo all' "Autorità di
certificazione".

Informazioni sul certificato:
- Scopo certificato: garantisce l'identità di un computer remoto
- Rilasciato a: www.XYZ.com
- Rilasciato da: DittaCA
- Valido dal 07/03/2006 al 07/03/2007.

Nell'IIS, dentro la configurazione del sito, in "Sito Web" ho impostato
"Porta SSL: 443", mentre in "Protezione directory" ho selezionato solo
"Richiedi un canale protetto (SSL)" e "Ignora certificati dei client".

Se dal browser digito https://www.xyz.com mi restituisce "Impossibile
trovare il server".

Help? :-)
Grazie!
JD
Gatsu
2006-03-09 13:41:22 UTC
Permalink
Post by Gatsu
Help? :-)
Aggiungo che il server web ha un solo indirizzo IP e che lato IIS:

Sito Web:
Indirizzo IP: (nessuno)
Porta TCP: 80
Porta SSL: 443

Avanzate -> Identità multiple per questo sito Web
Indirizzo IP: (nessuno)
Porta TCP: 80
Intestazione host: www.XYZ.com

Avanzate -> Configurazione avanzata sito Web multiplo
Indirizzo IP: (nessuno)
Porta SSL: 443

Help? :-)
Edoardo Benussi [MVP]
2006-03-09 14:05:42 UTC
Permalink
Post by Gatsu
Post by Gatsu
Help? :-)
Indirizzo IP: (nessuno)
Porta TCP: 80
Porta SSL: 443
Avanzate -> Identità multiple per questo sito Web
Indirizzo IP: (nessuno)
Porta TCP: 80
Intestazione host: www.XYZ.com
Avanzate -> Configurazione avanzata sito Web multiplo
Indirizzo IP: (nessuno)
Porta SSL: 443
prova a mettere l'host header name
www.XYZ.com
anche per https
--
Edoardo Benussi - ***@mvps.org
Microsoft® MVP - Windows Server
http://mvp.support.microsoft.com
Gatsu
2006-03-09 14:24:21 UTC
Permalink
prova a mettere l'host header name www.XYZ.com anche per https
Non mi è possibile, non esiste il campo "Intestazione host".
Alessandro Borille [MVP]
2006-03-09 14:28:04 UTC
Permalink
Post by Gatsu
prova a mettere l'host header name www.XYZ.com anche per https
Non mi è possibile, non esiste il campo "Intestazione host".
È corretto. Per connessioni SSL fa fede quello scritto nel
certificato.
--
Alessandro Borille
Visita http://www.alessandraorsolato.it
Scrittrice emergente - Thriller - Gialli
Alessandro Borille [MVP]
2006-03-09 14:11:13 UTC
Permalink
Post by Gatsu
Se dal browser digito https://www.xyz.com mi restituisce "Impossibile
trovare il server".
Messa così sembra un banale problema di risoluzione. Il dns che
interroghi non sa chi sia www.xyz.com

Se devi fare dei test puoi infilare una riga nel file
%systemroot%\system32\drivers\etc\hosts
--
Alessandro Borille
Visita http://www.alessandraorsolato.it
Scrittrice emergente - Thriller - Gialli
Gatsu
2006-03-09 14:28:50 UTC
Permalink
Se devi fare dei test puoi infilare una riga nel file %systemroot%\system32\drivers\etc\hosts
Non credo sia necessario. Dal server web riesco a pingare benissimo
www.xyz.com e, sempre dal server web, il browser mi restituisce lo
stesso errore, anche dopo aver deselezionato dalle proprietà di IE la
voce "Mostra messaggi di errore HTTP brevi" e dopo aver cancellato
cookies, certificati, ecc.
Alessandro Borille [MVP]
2006-03-09 14:37:15 UTC
Permalink
Post by Gatsu
Se devi fare dei test puoi infilare una riga nel file %systemroot%\system32\drivers\etc\hosts
Non credo sia necessario. Dal server web riesco a pingare benissimo
www.xyz.com e, sempre dal server web, il browser mi restituisce lo
stesso errore, anche dopo aver deselezionato dalle proprietà di IE la
voce "Mostra messaggi di errore HTTP brevi" e dopo aver cancellato
cookies, certificati, ecc.
Settato qualche proxy?
Oppure il tuo caso è questo:
http://support.microsoft.com/kb/265847/en-us
--
Alessandro Borille
Visita http://www.alessandraorsolato.it
Scrittrice emergente - Thriller - Gialli
Gatsu
2006-03-09 14:44:29 UTC
Permalink
Niente proxy.
Leggendo quel link pare che debba in pratica rimuovere e ricreare il
certificato, operazione già provata.
Alessandro Borille [MVP]
2006-03-09 14:56:35 UTC
Permalink
Post by Gatsu
Niente proxy.
Leggendo quel link pare che debba in pratica rimuovere e ricreare il
certificato, operazione già provata.
Segui alla lettera il link e non presumere nulla.
--
Alessandro Borille
Visita http://www.alessandraorsolato.it
Scrittrice emergente - Thriller - Gialli
Gatsu
2006-03-09 15:28:20 UTC
Permalink
Post by Alessandro Borille [MVP]
Segui alla lettera il link e non presumere nulla
Ok, capisco. Ho rimosso i "Servizi Certificati da "Installazione
Applicazioni" e mi accingo a reinstallarli.
Mi torna il quesito a cui non mi avevate dato purtroppo risposta.

Mi viene chiesto se voglio installare una CA GLOBALE-ENTERPRISE
(principale o subordinata; entrambe richiedono Active Directory) o
AUTONOMA-STANDALONE (principale o subordinata) e poi posso selezionare
"Opzioni
avanzate".

Prima avevo scelto CA AUTONOMA-STANDALONE PRINCIPALE, perchè non
volevo "toccare" Active Directory. Posso rifare la stessa scelta o è
meglio che imposti "CA GLOGALE-ENTERPRISE PRINCIPALE"?
Alessandro Borille [MVP]
2006-03-09 15:37:11 UTC
Permalink
Post by Gatsu
Prima avevo scelto CA AUTONOMA-STANDALONE PRINCIPALE, perchè non
volevo "toccare" Active Directory. Posso rifare la stessa scelta o è
meglio che imposti "CA GLOGALE-ENTERPRISE PRINCIPALE"?
Per il tuo scopo è indifferente.
--
Alessandro Borille
Visita http://www.alessandraorsolato.it
Scrittrice emergente - Thriller - Gialli
Gatsu
2006-03-10 10:24:57 UTC
Permalink
Post by Alessandro Borille [MVP]
Per il tuo scopo è indifferente.
Ci rinuncio, vi ringrazio moltissimo.
Sono convinto di fare tutti i passaggi giusti. O sbaglio in qualche
parte o qualcos'altro non funziona.
Aspetto tempi migliori o un nuovo server.

Grazie ancora!
JD
Edoardo Benussi [MVP]
2006-03-10 10:36:59 UTC
Permalink
Post by Gatsu
Post by Alessandro Borille [MVP]
Per il tuo scopo è indifferente.
Ci rinuncio, vi ringrazio moltissimo.
peccato.
--
Edoardo Benussi - ***@mvps.org
Microsoft® MVP - Windows Server
http://mvp.support.microsoft.com
Gatsu
2006-03-13 16:32:22 UTC
Permalink
Post by Edoardo Benussi [MVP]
peccato
Ciao,
stavo ancora provando a installare un certificato di test. Non ci
riesco neppure con alcuni trial. Non è che magari i passi che compio
sono corretti ma non funziona perchè il mio server web ha un solo
indirizzo ip, come viene scritto qui:
http://www.igate.it/certificati/requisiti_tecnici.htm

Grazie
Gatsu
2006-03-15 07:55:20 UTC
Permalink
non funziona perchè il mio server web ha un solo indirizzo ip?
Potrebbe essere questa la causa dei miei... "insuccessi"? :-)
Edoardo Benussi [MVP]
2006-03-15 09:17:36 UTC
Permalink
Post by Gatsu
non funziona perchè il mio server web ha un solo indirizzo ip?
Potrebbe essere questa la causa dei miei... "insuccessi"? :-)
no, neanche questo c'entra.
--
Edoardo Benussi - ***@mvps.org
Microsoft® MVP - Windows Server
http://mvp.support.microsoft.com
Continua a leggere su narkive:
Risultati di ricerca per 'Connessione HTTPS su IIS' (newsgroup and mailinglist)
14
risposte
Tunneling Https
iniziato 2005-03-07 11:53:02 UTC
microsoft.public.it.winserver
12
risposte
Configurare correttamente IIS 5.0 per ASP e MDB
iniziato 2004-07-30 19:05:25 UTC
microsoft.public.it.winserver
25
risposte
SSL per IIS 5.0
iniziato 2004-01-20 11:13:58 UTC
microsoft.public.it.winserver
7
risposte
Chiarimenti su utilizzo SSL in IIS....
iniziato 2007-04-30 10:45:42 UTC
microsoft.public.it.windowsxp
12
risposte
Certificati per connessione https
iniziato 2005-02-01 12:20:59 UTC
microsoft.public.it.winserver
Risultati di ricerca per 'Connessione HTTPS su IIS' (Domande e Risposte)
3
risposte
Come assicurarsi che i cookie vengano sempre inviati tramite SSL quando si utilizza ASP.NET su IIS 7.5?
iniziato 2011-01-09 04:24:12 UTC
sicurezza
14
risposte
Com'è possibile che le persone che osservano una connessione HTTPS stabilita non sappiano come decrittografarla?
iniziato 2011-08-15 23:58:32 UTC
sicurezza
5
risposte
Come correggere SSL 2.0 e BEAST su IIS
iniziato 2012-04-30 17:14:51 UTC
sicurezza
6
risposte
Esiste un repository Internet simile a Git per la collaborazione su carta?
iniziato 2012-11-13 04:24:45 UTC
università
1
rispondi
Connessione Ethernet RPi zero tramite porta HDMI utilizzando un adattatore da HDMI a RJ45
iniziato 2016-08-26 17:42:42 UTC
raspberry pi
Discussioni interessanti ma non correlate
7
risposte
4 giorni a Parigi
iniziato 2012-06-13 18:21:44 UTC
6
risposte
Utilizzo della carta di credito Visa in Danimarca, Germania, Islanda
iniziato 2016-09-19 04:29:34 UTC
7
risposte
È sicuro guidare da Praga a Salisburgo durante l'inverno?
iniziato 2019-12-06 18:43:31 UTC
7
risposte
Quanto essere onesto con l'immigrazione statunitense riguardo all'incertezza sui piani di viaggio?
iniziato 2019-10-03 14:08:53 UTC
5
risposte
Come pesate i bagagli?
iniziato 2014-12-14 00:54:52 UTC
Loading...