Discussione:
Non risolvo un dominio (OT?)
(troppo vecchio per rispondere)
Gatsu
2005-09-28 07:37:40 UTC
Permalink
Ciao,

scusatemi, se sono OT indicatemi cortesemente il NG + adatto.

Ho 3 dns pubblici (sono un ISP) e nessuno di questi mi risolve il
dominio jninc.com.

I dns di altri operatori lo risolvono.

Nei miei dns uso i root-servers, gli ip li ho verificati e sono
corretti (eccetto per il b.root-servers.net = 128.9.0.107 o
192.228.79.201?).

Facendo un traceroute arrivo a destinazione e se inserisco l'indirizzo
ip del record mx di quel dominio mi appare la pagina del sito
incriminato.

Un problema di Dns? Non credo.. il provider di quel dominio mi ha
inserito in una black list??

Grazie!!!
JD
ObiWan
2005-09-28 08:07:46 UTC
Permalink
Post by Gatsu
Ciao,
Ciao
Post by Gatsu
Ho 3 dns pubblici (sono un ISP) e nessuno di questi mi risolve il
dominio jninc.com.
I dns di altri operatori lo risolvono.
Hmm .. prima di tutto verifica che i DNS siano in grado di effettuare
queries (e di rispondere a queries se non pubblici) sia su UDP che
su TCP, ossia, traffico da/per 53/TCP e 53/UDP e NON SOLO su
UDP altrimenti potresti avere qualche problema; poi, disabilita l'uso
di EDNS0 sui tuoi DNS (vedi http://support.microsoft.com/kb/828731)
e quindi svuota la cache e ritenta le queries
Post by Gatsu
Nei miei dns uso i root-servers, gli ip li ho verificati e sono
corretti (eccetto per il b.root-servers.net = 128.9.0.107 o
192.228.79.201?).
I root hints sono aggiornabili, in win2003 ti basterà aprire il pannello
di config relativo ai root hints e cliccare il bottone di aggiornamento
dal server immettendo poi l'indirizzo 198.41.0.4 (a.root-servers.net)
ad ogni modo i root hints attuali sono:

. 518400 IN NS A.ROOT-SERVERS.NET.
. 518400 IN NS B.ROOT-SERVERS.NET.
. 518400 IN NS C.ROOT-SERVERS.NET.
. 518400 IN NS D.ROOT-SERVERS.NET.
. 518400 IN NS E.ROOT-SERVERS.NET.
. 518400 IN NS F.ROOT-SERVERS.NET.
. 518400 IN NS G.ROOT-SERVERS.NET.
. 518400 IN NS H.ROOT-SERVERS.NET.
. 518400 IN NS I.ROOT-SERVERS.NET.
. 518400 IN NS J.ROOT-SERVERS.NET.
. 518400 IN NS K.ROOT-SERVERS.NET.
. 518400 IN NS L.ROOT-SERVERS.NET.
. 518400 IN NS M.ROOT-SERVERS.NET.
A.ROOT-SERVERS.NET. 3600000 IN A 198.41.0.4
B.ROOT-SERVERS.NET. 3600000 IN A 192.228.79.201
C.ROOT-SERVERS.NET. 3600000 IN A 192.33.4.12
D.ROOT-SERVERS.NET. 3600000 IN A 128.8.10.90
E.ROOT-SERVERS.NET. 3600000 IN A 192.203.230.10
F.ROOT-SERVERS.NET. 3600000 IN A 192.5.5.241
G.ROOT-SERVERS.NET. 3600000 IN A 192.112.36.4
H.ROOT-SERVERS.NET. 3600000 IN A 128.63.2.53
I.ROOT-SERVERS.NET. 3600000 IN A 192.36.148.17
J.ROOT-SERVERS.NET. 3600000 IN A 192.58.128.30
K.ROOT-SERVERS.NET. 3600000 IN A 193.0.14.129
L.ROOT-SERVERS.NET. 3600000 IN A 198.32.64.12
M.ROOT-SERVERS.NET. 3600000 IN A 202.12.27.33


prova quanto sopra e fammi (facci, il newsgroup) sapere
Gatsu
2005-09-28 09:39:26 UTC
Permalink
verifica che i DNS siano in grado di effettuare traffico UDP
disabilita l'uso di EDNS0 sui tuoi DNS
svuota la cache
ritenta le queries
Fatto tutte queste cose su uno dei tre Dns, ma niente! :-(
ObiWan
2005-09-28 10:44:40 UTC
Permalink
Post by Gatsu
verifica che i DNS siano in grado di effettuare traffico
UDP disabilita l'uso di EDNS0 sui tuoi DNS svuota la
cache ritenta le queries
Fatto tutte queste cose su uno dei tre Dns, ma niente! :-(
Hmm .. potresti per favore verificare se il DNS è configurato
con qualche forwarder ? Inoltre, accertati che la ricorsione
non sia disabilitata.

Fatto questo, prova ad aprire (dalla console) un prompt comandi
ed immetti il comando

nslookup -type=MX microsoft.com

quindi immetti "nslookup" da solo, ti verrà presentato il "prompt" (>)
immetti i seguenti comandi

server 217.146.139.5
www.microsoft.com
set vc
www.yahoo.com

poi copia/incolla il contenuto della console (includendo entrambi i
tests) e vediamo di capire dove si "incastrano" le cose

Ciao
--
* ObiWan

Microsoft MVP: Windows Server - Networking
http://www.microsoft.com/communities/MVP/MVP.mspx
http://italy.mvps.org

DNS "fail-safe" for Windows clients.
http://www.ntcanuck.com

Newsgroups and forums
news://news.ntcanuck.com
http://forums.ntcanuck.com

408+ XP/2000 tweaks and tips
http://www.ntcanuck.com/tq/Tip_Quarry.htm
Gatsu
2005-09-28 12:17:12 UTC
Permalink
Ecco!

C:\Documents and Settings\Administrator>nslookup -type=MX microsoft.com
Server: dns.trivenet.it
Address: 212.103.192.10

Non-authoritative answer:
microsoft.com MX preference = 10, mail exchanger =
mailc.microsoft.com
microsoft.com MX preference = 10, mail exchanger =
maila.microsoft.com
microsoft.com MX preference = 10, mail exchanger =
mailb.microsoft.com

mailc.microsoft.com internet address = 207.46.121.52
mailc.microsoft.com internet address = 207.46.121.53
maila.microsoft.com internet address = 131.107.3.124
maila.microsoft.com internet address = 131.107.3.125
mailb.microsoft.com internet address = 207.46.121.51
mailb.microsoft.com internet address = 131.107.3.123

C:\Documents and Settings\Administrator>nslookup
Default Server: dns.trivenet.it
Address: 212.103.192.10
Post by ObiWan
server 217.146.139.5
Default Server: ns1.de.eu.orsn.net
Address: 217.146.139.5
Post by ObiWan
www.microsoft.com
Server: ns1.de.eu.orsn.net
Address: 217.146.139.5

Non-authoritative answer:
Name: lb1.www.ms.akadns.net
Addresses: 207.46.19.60, 207.46.19.30, 207.46.225.60, 207.46.199.30
207.46.198.60, 207.46.199.60
Aliases: www.microsoft.com, toggle.www.ms.akadns.net
g.www.ms.akadns.net
Post by ObiWan
set vc
www.yahoo.com
Server: ns1.de.eu.orsn.net
Address: 217.146.139.5

*** ns1.de.eu.orsn.net can't find www.yahoo.com: Server failed
Gatsu
2005-09-28 12:21:16 UTC
Permalink
Ecco! Tra asterischi ho sostituito il nome della mia azienda e l'ip del
mio Dns. Grazie di cuore!

C:\Documents and Settings\Administrator>nslookup -type=MX microsoft.com
Server: dns.*nomemiazienda*.it
Address: *indirizzo ip mio dns*

Non-authoritative answer:
microsoft.com MX preference = 10, mail exchanger =
mailc.microsoft.com
microsoft.com MX preference = 10, mail exchanger =
maila.microsoft.com
microsoft.com MX preference = 10, mail exchanger =
mailb.microsoft.com

mailc.microsoft.com internet address = 207.46.121.52
mailc.microsoft.com internet address = 207.46.121.53
maila.microsoft.com internet address = 131.107.3.124
maila.microsoft.com internet address = 131.107.3.125
mailb.microsoft.com internet address = 207.46.121.51
mailb.microsoft.com internet address = 131.107.3.123

C:\Documents and Settings\Administrator>nslookup
Default Server: dns.*nomemiazienda*.it
Address: *indirizzo ip mio dns*
Post by ObiWan
server 217.146.139.5
Default Server: ns1.de.eu.orsn.net
Address: 217.146.139.5
Post by ObiWan
www.microsoft.com
Server: ns1.de.eu.orsn.net
Address: 217.146.139.5

Non-authoritative answer:
Name: lb1.www.ms.akadns.net
Addresses: 207.46.19.60, 207.46.19.30, 207.46.225.60, 207.46.199.30
207.46.198.60, 207.46.199.60
Aliases: www.microsoft.com, toggle.www.ms.akadns.net
g.www.ms.akadns.net
Post by ObiWan
set vc
www.yahoo.com
Server: ns1.de.eu.orsn.net
Address: 217.146.139.5

*** ns1.de.eu.orsn.net can't find www.yahoo.com: Server failed
ObiWan
2005-09-28 12:43:59 UTC
Permalink
Post by Gatsu
Ecco! Tra asterischi ho sostituito il nome della
mia azienda e l'ip del mio Dns. Grazie di cuore!
Ehm .. nel primo post non lo hai fatto, cmq non è
un problema, per risalire alla tua azienda basta
un whois sul tuo indirizzo IP .. reperibile dagli
headers dei posts :-) .. di nuovo, NON è un problema
Post by Gatsu
C:\Documents and Settings\Administrator>nslookup -type=MX microsoft.com
Server: dns.*nomemiazienda*.it
Address: *indirizzo ip mio dns*
microsoft.com MX preference = 10, mail exchanger =
<snip>

E fin qui tutto bene...
Post by Gatsu
C:\Documents and Settings\Administrator>nslookup
Default Server: dns.*nomemiazienda*.it
Address: *indirizzo ip mio dns*
Post by ObiWan
server 217.146.139.5
Default Server: ns1.de.eu.orsn.net
Address: 217.146.139.5
Post by ObiWan
www.microsoft.com
Server: ns1.de.eu.orsn.net
Address: 217.146.139.5
Name: lb1.www.ms.akadns.net
Addresses: 207.46.19.60, 207.46.19.30, 207.46.225.60, 207.46.199.30
207.46.198.60, 207.46.199.60
Aliases: www.microsoft.com, toggle.www.ms.akadns.net
g.www.ms.akadns.net
ancora Ok
Post by Gatsu
Post by ObiWan
set vc
www.yahoo.com
Server: ns1.de.eu.orsn.net
Address: 217.146.139.5
*** ns1.de.eu.orsn.net can't find www.yahoo.com: Server failed
Eccoci qui; l'opzione "set vc" forza nslookup ad utilizzare TCP
per le queries, ora, il fatto che la query sia finita in errore significa
che la macchina sulla quale "gira" il DNS non è in grado di effettuare
queries verso l'esterno utilizzando il protocollo TCP; ti consiglio di
verificare MOLTO attentamente le impostazioni del firewall e di
permettere queries in uscita verso la porta 53/TCP (oltre che
-ovviamente- verso la 53/UDP)

Ciao
--
* ObiWan

Microsoft MVP: Windows Server - Networking
http://www.microsoft.com/communities/MVP/MVP.mspx
http://italy.mvps.org

DNS "fail-safe" for Windows clients.
http://www.ntcanuck.com

Newsgroups and forums
news://news.ntcanuck.com
http://forums.ntcanuck.com

408+ XP/2000 tweaks and tips
http://www.ntcanuck.com/tq/Tip_Quarry.htm
Gatsu
2005-09-28 12:52:49 UTC
Permalink
Faccio controllare subito, ma come posso reimpostare la configurazione
pre "set vc"?
Grazie ancora
Gatsu
2005-09-28 13:09:55 UTC
Permalink
ti consiglio di verificare MOLTO attentamente le impostazioni del firewall e di permettere queries in uscita verso la porta 53/TCP (oltre che -ovviamente- verso la 53/UDP)
Chi configura il ns firewall dice che è permesso il traffico relativo
alla porta 53, sia tcp che udp. Dov'è l'inghippo? :-(
ObiWan
2005-09-28 13:40:33 UTC
Permalink
Post by Gatsu
ti consiglio di verificare MOLTO attentamente
le impostazioni del firewall e di permettere queries
in uscita verso la porta 53/TCP (oltre che -ovviamente-
verso la 53/UDP)
Chi configura il ns firewall dice che è permesso il traffico
relativo alla porta 53, sia tcp che udp. Dov'è l'inghippo? :-(
Hmm.. mi suona MOLTO strano; ammesso che sul server DNS
non ci sia software di port filtering (s/w firewall o altro) il test fatto
con nslookup non lascia dubbi sul fatto che le connessioni verso
la porta 53/TCP in USCITA dal DNS (in ingresso funzionano, forse
è qui che si è confuso il "gestore del firewall") siano bloccate

Una prova rapida; prova ad usare "telnet" per connetterti ad un DNS
esterno (ovviamente sulla 53/TCP) in pratica, dal prompt comandi
immetti il comando

telnet 217.146.139.5 53

se tutto funziona dovresti vedere il cursore lampeggiare e non avere
alcun errore, in caso contrario telnet ti restituirà un errore relativo
all'impossibilità di effettuare la connessione, questa sarebbe una
ulteriore prova del fatto che la 53/tcp è CHIUSA in uscita

Ciao
--
* ObiWan

Microsoft MVP: Windows Server - Networking
http://www.microsoft.com/communities/MVP/MVP.mspx
http://italy.mvps.org

DNS "fail-safe" for Windows clients.
http://www.ntcanuck.com

Newsgroups and forums
news://news.ntcanuck.com
http://forums.ntcanuck.com

408+ XP/2000 tweaks and tips
http://www.ntcanuck.com/tq/Tip_Quarry.htm
ObiWan
2005-09-28 13:08:50 UTC
Permalink
Post by Gatsu
Faccio controllare subito, ma come
posso reimpostare la configurazione
pre "set vc"?
In che senso scusa ? La "set vc" è un'opzione
di nslookup, basta chiudere nslookup ed al
successivo avvio ripartirà "senza vc", non si
tratta di un'impostazione del DNS; nslookup
è un programma per effettuare queries verso
qualsiasi DNS !

Ma .. scusa, ti sei presentato con un "sono un
ISP" il che come minimo _presuppone_ un
certo livello di conoscenza.. invece da certe
domande sembra che tale conoscenza non
esista affatto.. mi sta venendo qualche dubbio...

.. resta il fatto che il tuo DNS pur _rispondendo_
(ho verificato) a queries TCP, *NON* riesce ad
utilizzare TCP per effettuare queries verso DNS
esterni cosa questa che può causare non pochi
problemi relativamente alla risoluzione di nomi
ed in particolare al funzionamento di servers
SMTP (e-mail)

Ciao
--
* ObiWan

Microsoft MVP: Windows Server - Networking
http://www.microsoft.com/communities/MVP/MVP.mspx
http://italy.mvps.org

DNS "fail-safe" for Windows clients.
http://www.ntcanuck.com

Newsgroups and forums
news://news.ntcanuck.com
http://forums.ntcanuck.com

408+ XP/2000 tweaks and tips
http://www.ntcanuck.com/tq/Tip_Quarry.htm
Gatsu
2005-09-28 13:25:56 UTC
Permalink
La "set vc" è un'opzione di nslookup
Hai ragione, scusami, sai com'è.. appena sento il termine "set" mi
assale il panico :-)
"sono un ISP"
L'ho premesso innanzitutto per anticipare suggerimenti del tipo "chiedi
al tuo provider, hai un forward verso il dns del tuo provider, ecc.".
In ogni caso so alcune cose, ma non proprio tutto..
*NON* riesce ad utilizzare TCP per effettuare queries verso DNS esterni
Tornerò alla carica con chi amministra il firewall, o credi si debba
intervenire altrove? A livello di scheda di rete non riscontro alcuna
restrizione particolare..

Grazie!
Gatsu
2005-09-28 15:18:05 UTC
Permalink
Post by ObiWan
porta 53
Ho avuto la conferma che la porta 53/TCP è abilitata. Prova ne è che
il Firewall vede tale traffico e lo fa passare, considerando anche che
il telnet funziona.

Cos'altro può essere secondo te?
ObiWan
2005-09-28 15:23:42 UTC
Permalink
Post by Gatsu
Post by ObiWan
porta 53
Ho avuto la conferma che la porta 53/TCP è abilitata.
Prova ne è che il Firewall vede tale traffico e lo fa passare,
considerando anche che il telnet funziona.
Cos'altro può essere secondo te?
Hmm qui "gatta cigogna" come diceva un tizio; ok.. iniziamo
dall'event log; verifica nel registro eventi del DNS e vedi se
trovi warnings o errori; inoltre, nel pannello di configurazione
del DNS, abilita la diagnostica (sia per la query semplice che
per quella ricorsiva) e già che ci sei prova ad usare il bottone
"check now" per vedere se il test viene superato

Già che ci siamo; hai detto di aver disabilitato EDNS0 su uno
dei tre servers; ok.. prova a stoppare/riavviare il servizio DNS
su tale server e vediamo cosa succede
ObiWan
2005-09-28 15:40:56 UTC
Permalink
Post by Gatsu
Cos'altro può essere secondo te?
Già che c'ero e siccome sono un pochino
come S.Tommaso ho provato a verificare
il dominio "problematico" ed ecco cosa è
uscito fuori

http://www.dnsreport.com/tools/dnsreport.ch?domain=jninc.com

ho idea che il problema non sia soltanto dal
tuo lato; i tizi di jninc hanno dei DNS configurati
in maniera quantomeno "bizzarra" (eufemismo)
ad ogni modo.. prosegui con le verifiche che ti
ho consigliato e cerchiamo di venire a capo del
problema

Ciao
--
* ObiWan

Microsoft MVP: Windows Server - Networking
http://www.microsoft.com/communities/MVP/MVP.mspx
http://italy.mvps.org

DNS "fail-safe" for Windows clients.
http://www.ntcanuck.com

Newsgroups and forums
news://news.ntcanuck.com
http://forums.ntcanuck.com

408+ XP/2000 tweaks and tips
http://www.ntcanuck.com/tq/Tip_Quarry.htm
Gatsu
2005-09-28 15:54:32 UTC
Permalink
Della serie "prima provo le cose + semplici" riavviando i servizi ora
tutti e tre i Dns risolvono il dominio.

Non so però se è bastato questo oppure "loro" hanno fatto altri
interventi.

Meglio così!

Grazie infinite, mi rifarò vivo se dovesse ricapitarmi qualcosa!!!
ObiWan
2005-09-28 16:06:37 UTC
Permalink
Post by Gatsu
Della serie "prima provo le cose + semplici" riavviando
i servizi ora tutti e tre i Dns risolvono il dominio.
Ok, assicurati comunque di disabilitare EDNS0 su tutti e tre
i DNS, di svuotare la cache e di riavviare i servizi; ho idea
che il problema possa essere stato causato da qualche
errata impostazione DNS di "jninc" che è rimasta memorizzata
nella cache dei tuoi DNS a proposito, hai attivato l'opzione
"proteggi la cache contro l'inquinamento" VERO ? (no, non
si tratta di un filtro anti-smog :-D) anzi. già che ci siamo apri
le console dei DNS ed assicurati che non ci siano forwarders,
che la ricorsione non sia disabilitata, che i root-hints siano
aggiornati (al limite aggiornali, non farà male) e poi verifica
che siano "spuntate" solo le seguenti opzioni:

"BIND secondaries"
"Enable round robin"
"Enable netmask ordering"
"Secure cache against pollution"

quanto sopra per la versione inglese, in italiano hai comunque
le opzioni corrispondenti .. tradotte male, tipo "BIND dei secondari"
una volta completato quanto sopra e riavviato il servizio DNS
dovresti essere a posto

inoltre, già che ci sei prova a fare il test di "dnsreport" anche
per il TUO dominio; ti basta andare su www.dnsreport.com
ed immettere il nome del tuo dominio per verificare se la
configurazione dei DNS pubblici è corretta
Post by Gatsu
Grazie infinite, mi rifarò vivo se dovesse ricapitarmi qualcosa!!!
A disposizione :-)

Ciao
--
* ObiWan

Microsoft MVP: Windows Server - Networking
http://www.microsoft.com/communities/MVP/MVP.mspx
http://italy.mvps.org

DNS "fail-safe" for Windows clients.
http://www.ntcanuck.com

Newsgroups and forums
news://news.ntcanuck.com
http://forums.ntcanuck.com

408+ XP/2000 tweaks and tips
http://www.ntcanuck.com/tq/Tip_Quarry.htm
Continua a leggere su narkive:
Loading...