Discussione:
Sata Raid in un Sistema win Server 2003 già installato
(troppo vecchio per rispondere)
s***@bisight.com
2007-09-06 14:37:54 UTC
Permalink
Ciao,
ho un problema che non riesco a risolvere:
Su di un HP Proliant 110G ho installato Win Server 2003 su un hdd
sata.
Volevo aggiungere altri due hdd sata ed attivare il Raid Mirroring tra
questi ultimi due dischi.

Una volta configurato il bios (Enable Raid Sata), posso entrare nel
bios nel controller raid e creare gli array di hdd, ma durante il boot
di windows, dopo 3 secondi della classica schermata di caricamento
(finestra e barra di scorrimento), compare per un istante una bsod e
si riavvia la macchina... in un ciclo infinito!!!
Nel menu di creazione array, vedo il disco con installato il sistema
operativo e gli altri due dischi. Ma prima di creare il mirroring
volevo essere certo che almeno il sistema operativo partisse.

Disabilitando il raid tramite bios il server esegue il boot senza
problemi.

Grazie per ogni aiuto.
Stefano
OxygeN
2007-09-06 14:48:28 UTC
Permalink
Post by s***@bisight.com
Ciao,
Su di un HP Proliant 110G ho installato Win Server 2003 su un hdd
sata.
Volevo aggiungere altri due hdd sata ed attivare il Raid Mirroring tra
questi ultimi due dischi.
Una volta configurato il bios (Enable Raid Sata), posso entrare nel
bios nel controller raid e creare gli array di hdd, ma durante il boot
di windows, dopo 3 secondi della classica schermata di caricamento
(finestra e barra di scorrimento), compare per un istante una bsod e
si riavvia la macchina... in un ciclo infinito!!!
Credo che si tratti dell'errore 0000007b, praticamente il disco SATA dal
quale stai facendo boot non ha i driver per il controller in modalità RAID.
Purtroppo pero' non so come potresti procedere...
s***@bisight.com
2007-09-06 14:59:58 UTC
Permalink
OxygeN
2007-09-06 15:27:56 UTC
Permalink
Grazie per la celerità, non ti so dire il tipo di errore perchè la
bsod dura pochi istanti. Faccio appena in tempo ad intuire che è una
bsod che si riavvia il pc.
Rimetti tutto in modalità "IDE" (leva il RAID dal BIOS).
Riavvia il sistema, vai di "Tasto DX - Proprietà" su "Risorse del
computer", alla linguetta "Avanzate" clicca su "Impostazioni" alla voce
"Avvio e ripristino" e togli il segno di spunta da "Riavvia
automaticamente".
Riavvia il sistema, da BIOS riattiva il RAID e vedrai che alla prossima
BSOD si fermerà... leggi quello che ti dice e postalo...
I driver di installazione li ho scaricati dal sito di HP nella sezione
dedicata al modello del mio server.
A naso anche io mi ero dato questa risposta e la mia successiva
come faccio ad installare i driver del controller sata se non posso
abilitarlo?
Puoi forzare l'installazione di hardware non presente, credo...
Se lo abilito non parte windows, se non lo abilito posso lanciare i
driver ma non si installano perchè non c'è l'hardware.
E' un circolo viszioso... sono senza idee!
Io ho avuto un problema "inverso": sistema in RAID-1, aggiorno driver
RAID e mi fa BSOD.
Tolgo un disco, metto il BIOS in "IDE" e funziona, ma come te: non
potevo rimuovere i driver perchè l'hardware non veniva visto. Soluzione
intermedia: installare un controller SATA aggiuntivo, fare boot da
quello (quindi sposti il disco) e prima di cio' attivare nuovamente in
modalità "RAID" il controller integrato. A me non ha funzionato perchè
era un sistema x64 e non ci sono i driver per il controller aggiuntivo...

Fammi sapere se lo spunto ti ha aiutato
s***@bisight.com
2007-09-06 16:07:24 UTC
Permalink
s***@bisight.com
2007-09-06 16:29:32 UTC
Permalink
OxygeN
2007-09-07 06:22:45 UTC
Permalink
Ho installato i driver del raid, li ha aggiunti nella lista delle
periferiche hw installate sul pc... al riavvio solita bsod.
... quindi hai forzato l'installazione, senza pero' aver successo...
Altre idee?
Usare il CD di installazione di Windows Server e fare un [R]ipristina.
Ovviamente con il controller settato come "RAID".
A me ha funzionato e *non* ho perso configurazioni/impostazioni di
programmi già presenti...
s***@bisight.com
2007-09-07 07:10:43 UTC
Permalink
Roberto Bergonzini
2007-09-08 09:01:11 UTC
Permalink
Hello, ***@bisight.com!
You wrote on Thu, 06 Sep 2007 14:37:54 -0000:
Ci ho provato anch'io tante volte quando ad esempio cercavo di spostare
un'istallazione da un Server ad un secondo anche solo temporaneamente.
La logica dovrebbe essere quella di 'infilare' il driver nuovo
nell'installazione avviata. Semplicemente 'installando' il driver della
nuova controller.
Infatti se dovessi fare l'operazione contraria cioè spostare
un'installazione fatta con una controller RAID HW su disco singolo il S.O.
parte senza problemi perchè il S.O. ha già i driver nativi x dischi IDE o
SATA (o meglio si interfaccia con il BIOS).
Io ho spesso risolto il problema con un 'upgrade in place' rinfrescando cioè
l'installazione del S.O. dal momento che la richiesta del driver della
controller RAID nuova viene fatta propria all'inizio.

Prima però devi copiare l'installazione funzionante dal disco singolo alla
coppia di dischi in mirror.
Anche qui due soluzioni.
1. Abbini al disco singolo un 2° nuovo e dal BIOS della controller imposti
il 1° come 'primary', il 2° come 'secondary' e gli fai copiare il contenuto
del 1° su 2°
2. Usi un disco di Ghost (che supporti la controller RAID nuova) e fai la
copia dal disco singolo alla coppia di dischi già mirrorati.

sb> Una volta configurato il bios (Enable Raid Sata), posso entrare nel
sb> bios nel controller raid e creare gli array di hdd, ma durante il boot
sb> di windows, dopo 3 secondi della classica schermata di caricamento
sb> (finestra e barra di scorrimento), compare per un istante una bsod e
sb> si riavvia la macchina... in un ciclo infinito!!!
sb> Nel menu di creazione array, vedo il disco con installato il sistema
sb> operativo e gli altri due dischi. Ma prima di creare il mirroring
sb> volevo essere certo che almeno il sistema operativo partisse.

sb> Disabilitando il raid tramite bios il server esegue il boot senza
sb> problemi.


With best regards, Roberto Bergonzini. E-mail: ***@tiscali.it
Continua a leggere su narkive:
Loading...