Discussione:
Client che non vede il controller di dominio aggiuntivo
(troppo vecchio per rispondere)
LM
2005-06-15 07:43:02 UTC
Permalink
In una rete 2003 ho un DC e un controller aggiuntivo, più tutti i vari client
membri, tra i quali altri 2 server 2003.
Se provo a togliere il DC (lo spengo), tutti i client vengono autenticati
dal controller aggiuntivo, tranne un server 2003 che non lo vede (non riesco
neppure ad accedere). Solo con il DC Principale inserito, funziona.
Non riesco a capire perchè e cosa guardare (no errori in evn log). L'unica
differenza tra gli altri client è che il client che non funziona, ha la rete
settata a mano, ma ho controlato e non trovo (forse perchè non so cosa
guardare) problemi. Il settaggio include gli indirizzi dei 2 DNS e ovviamente
la stessa sottorete, oltre che l'abilitazione dei servizi di rete per la
condivizione.
Cosa controllo?

Grazie. Luca.
Stefano Fio
2005-06-15 07:56:46 UTC
Permalink
Post by LM
In una rete 2003 ho un DC e un controller aggiuntivo, più tutti i
vari client membri, tra i quali altri 2 server 2003.
Se provo a togliere il DC (lo spengo), tutti i client vengono
autenticati dal controller aggiuntivo, tranne un server 2003 che non
lo vede (non riesco neppure ad accedere). Solo con il DC Principale
inserito, funziona.
Non riesco a capire perchè e cosa guardare (no errori in evn log).
L'unica differenza tra gli altri client è che il client che non
funziona, ha la rete settata a mano, ma ho controlato e non trovo
(forse perchè non so cosa guardare) problemi. Il settaggio include
gli indirizzi dei 2 DNS e ovviamente la stessa sottorete, oltre che
l'abilitazione dei servizi di rete per la condivizione.
Cosa controllo?
Grazie. Luca.
Qualìè il dns al quale punta il server che non riesce a loggarsi?
Posta un ipconfig /all del dc che resta acceso e del server che non si
logga.

Ciao.
--
Stefano FIO - ***@securityarchitect.it
MCSE Security Windows Server NT/2K/2K3
MCT - CWNA - CCNA - CCDA
------------------------------------------------------------------
-This posting is provided "AS IS" with no warranties,
and confers no rights
- Le informazioni fornite in questo messaggio sono fornite
senza vincolo di garanzia e senza responsabilità alcuna
------------------------------------------------------------------
LM
2005-06-15 08:32:02 UTC
Permalink
Post by Stefano Fio
Post by LM
In una rete 2003 ho un DC e un controller aggiuntivo, più tutti i
vari client membri, tra i quali altri 2 server 2003.
Se provo a togliere il DC (lo spengo), tutti i client vengono
autenticati dal controller aggiuntivo, tranne un server 2003 che non
lo vede (non riesco neppure ad accedere). Solo con il DC Principale
inserito, funziona.
Non riesco a capire perchè e cosa guardare (no errori in evn log).
L'unica differenza tra gli altri client è che il client che non
funziona, ha la rete settata a mano, ma ho controlato e non trovo
(forse perchè non so cosa guardare) problemi. Il settaggio include
gli indirizzi dei 2 DNS e ovviamente la stessa sottorete, oltre che
l'abilitazione dei servizi di rete per la condivizione.
Cosa controllo?
Grazie. Luca.
Qualìè il dns al quale punta il server che non riesce a loggarsi?
Posta un ipconfig /all del dc che resta acceso e del server che non si
logga.
Ciao.
CONFIGURAZIONE DEL CONTROLLER PRINCIPALE:
Configurazione IP di Windows
Nome host . . . . . . . . . . . . . . : SERVER1
Suffisso DNS primario . . . . . . . . : dominio.it
Tipo nodo . . . . . . . . . . . . . . : Sconosciuto
Routing IP abilitato . . . . . . . . : Sì
Proxy WINS abilitato . . . . . . . . : Sì
Elenco di ricerca suffissi DNS. . . . : dominio.it
Scheda Ethernet Connessione alla rete locale (LAN) del server:
Suffisso DNS specifico per connessione:
Descrizione . . . . . . . . . . . . . : 3Com EtherLink 10/100 PCI For
Complete PC Management NIC (3C905C-TX)
Indirizzo fisico. . . . . . . . . . . : 00-04-76-DE-7B-45
DHCP abilitato. . . . . . . . . . . . : No
Indirizzo IP. . . . . . . . . . . . . : 10.0.0.2
Subnet mask . . . . . . . . . . . . . : 255.255.255.0
Gateway predefinito . . . . . . . . . :
Server DNS . . . . . . . . . . . . . : 10.0.0.2
Server WINS primario . . . . . . . . : 10.0.0.2

CONFIGURAZIONE DEL CONTROLLER AGGIUNTIVO
Configurazione IP di Windows
Nome host . . . . . . . . . . . . . . : SERVER2
Suffisso DNS primario . . . . . . . . : DOMINIO.IT
Tipo nodo . . . . . . . . . . . . . . : Sconosciuto
Routing IP abilitato. . . . . . . . . : No
Proxy WINS abilitato . . . . . . . . : No
Elenco di ricerca suffissi DNS. . . . : DOMINIO.IT

Scheda Ethernet Connessione alla rete locale (LAN):
Suffisso DNS specifico per connessione: dominio.it
Descrizione . . . . . . . . . . . . . : Intel(R) PRO/100+ PCI Adapter
Indirizzo fisico. . . . . . . . . . . : 00-A0-C9-A0-85-AD
DHCP abilitato. . . . . . . . . . . . : No
Indirizzo IP. . . . . . . . . . . . . : 10.0.0.8
Subnet mask . . . . . . . . . . . . . : 255.255.255.0
Gateway predefinito . . . . . . . . . :
Server DNS . . . . . . . . . . . . . : 10.0.0.8
10.0.0.2

CONFIGURAZIONE CLIENT CHE NON VEDE IL SERVER AGGIUNTIVO
Configurazione IP di Windows
Nome host . . . . . . . . . . . . . . : server_db
Suffisso DNS primario . . . . . . . . : DOMINIO.IT
Tipo nodo . . . . . . . . . . . . . . : Sconosciuto
Routing IP abilitato. . . . . . . . . : No
Proxy WINS abilitato . . . . . . . . : No
Elenco di ricerca suffissi DNS. . . . : DOMINIO.IT
Scheda Ethernet Connessione alla rete locale (LAN):
Suffisso DNS specifico per connessione: dominio.it
Descrizione . . . . . . . . . . . . . : Intel(R) PRO/1000 CT Desktop
Connection
Indirizzo fisico. . . . . . . . . . . : 00-01-29-50-32-FF
DHCP abilitato. . . . . . . . . . . . : No
Indirizzo IP. . . . . . . . . . . . . : 10.0.0.3
Subnet mask . . . . . . . . . . . . . : 255.255.255.0
Gateway predefinito . . . . . . . . . :
Server DNS . . . . . . . . . . . . . : 10.0.0.2
10.0.0.8


Ciao e grazie. Luca
Stefano Fio
2005-06-15 08:51:00 UTC
Permalink
LM wrote:
[cut]
Post by LM
Configurazione IP di Windows
Nome host . . . . . . . . . . . . . . : SERVER1
Suffisso DNS primario . . . . . . . . : dominio.it
Tipo nodo . . . . . . . . . . . . . . : Sconosciuto
Routing IP abilitato . . . . . . . . : Sì
Proxy WINS abilitato . . . . . . . . : Sì
Elenco di ricerca suffissi DNS. . . . : dominio.it
Descrizione . . . . . . . . . . . . . : 3Com EtherLink 10/100 PCI
For Complete PC Management NIC (3C905C-TX)
Indirizzo fisico. . . . . . . . . . . : 00-04-76-DE-7B-45
DHCP abilitato. . . . . . . . . . . . : No
Indirizzo IP. . . . . . . . . . . . . : 10.0.0.2
Subnet mask . . . . . . . . . . . . . : 255.255.255.0
Server DNS . . . . . . . . . . . . . : 10.0.0.2
Server WINS primario . . . . . . . . : 10.0.0.2
CONFIGURAZIONE DEL CONTROLLER AGGIUNTIVO
Configurazione IP di Windows
Nome host . . . . . . . . . . . . . . : SERVER2
Suffisso DNS primario . . . . . . . . : DOMINIO.IT
Tipo nodo . . . . . . . . . . . . . . : Sconosciuto
Routing IP abilitato. . . . . . . . . : No
Proxy WINS abilitato . . . . . . . . : No
Elenco di ricerca suffissi DNS. . . . : DOMINIO.IT
Suffisso DNS specifico per connessione: dominio.it
Descrizione . . . . . . . . . . . . . : Intel(R) PRO/100+ PCI
Adapter Indirizzo fisico. . . . . . . . . . . : 00-A0-C9-A0-85-AD
DHCP abilitato. . . . . . . . . . . . : No
Indirizzo IP. . . . . . . . . . . . . : 10.0.0.8
Subnet mask . . . . . . . . . . . . . : 255.255.255.0
Server DNS . . . . . . . . . . . . . : 10.0.0.8
10.0.0.2
CONFIGURAZIONE CLIENT CHE NON VEDE IL SERVER AGGIUNTIVO
Configurazione IP di Windows
Nome host . . . . . . . . . . . . . . : server_db
Suffisso DNS primario . . . . . . . . : DOMINIO.IT
Tipo nodo . . . . . . . . . . . . . . : Sconosciuto
Routing IP abilitato. . . . . . . . . : No
Proxy WINS abilitato . . . . . . . . : No
Elenco di ricerca suffissi DNS. . . . : DOMINIO.IT
Suffisso DNS specifico per connessione: dominio.it
Descrizione . . . . . . . . . . . . . : Intel(R) PRO/1000 CT
Desktop Connection
Indirizzo fisico. . . . . . . . . . . : 00-01-29-50-32-FF
DHCP abilitato. . . . . . . . . . . . : No
Indirizzo IP. . . . . . . . . . . . . : 10.0.0.3
Subnet mask . . . . . . . . . . . . . : 255.255.255.0
Server DNS . . . . . . . . . . . . . : 10.0.0.2
10.0.0.8
La configurazione è corretta.
A questo punto i dubbi sono:

Dici che gli altri client riescono a loggarsi... (forse perchè vengono
autenticati... forse perche usano cached credential..)
Il primo test che ti consiglio è di verificare che il dns (10.0.0.8)
contenga i corretti record SRV.

Apri la console dns (10.0.0.8) e verifica che sotto
DOMINIO.IT->_sites->NomeSite(prob. Default-First-Site-Name)->_tcp
siano presenti almeno due(uno deve puntare ad un dc e l'altro deve puntare
all'altro) per ognuno di questi SRV record: _kerberos,_ldap,
se per il record _gc ne trovi solo uno, promuovi a "global catalog" anche
l'altro DC (il 10.0.0.8).

Poi lancia un dcdiag ed un netdiag e verifica se taluni test non passano.

Ciao!
--
Stefano FIO - ***@securityarchitect.it
MCSE Security Windows Server NT/2K/2K3
MCT - CWNA - CCNA - CCDA
------------------------------------------------------------------
-This posting is provided "AS IS" with no warranties,
and confers no rights
- Le informazioni fornite in questo messaggio sono fornite
senza vincolo di garanzia e senza responsabilità alcuna
------------------------------------------------------------------
LM
2005-06-15 09:24:03 UTC
Permalink
[...]
Post by Stefano Fio
Dici che gli altri client riescono a loggarsi... (forse perchè vengono
autenticati... forse perche usano cached credential..)
Il primo test che ti consiglio è di verificare che il dns (10.0.0.8)
contenga i corretti record SRV.
Apri la console dns (10.0.0.8) e verifica che sotto
DOMINIO.IT->_sites->NomeSite(prob. Default-First-Site-Name)->_tcp
siano presenti almeno due(uno deve puntare ad un dc e l'altro deve puntare
all'altro) per ognuno di questi SRV record: _kerberos,_ldap,
se per il record _gc ne trovi solo uno, promuovi a "global catalog" anche
l'altro DC (il 10.0.0.8).
Poi lancia un dcdiag ed un netdiag e verifica se taluni test non passano.
Effettivamente era proprio una cosa banale ed il server 10.0.0.8 non era un
Global Catalog. (o meglio in realtà era selezionata l'opzione ed infatti mi
sembrava di averlo fatto a suo tempo, ma nel DNS non esisteva il record _gc
relativo). Non so cosa possa essere successo... Comunque ho rimosso l'opzione
e l'ho rimessa. Dopo 5 minuti tutto è ricomparso nel DNS.

Grazie. Luca.
Stefano Fio
2005-06-15 09:24:50 UTC
Permalink
Post by LM
[...]
Post by Stefano Fio
Dici che gli altri client riescono a loggarsi... (forse perchè
vengono autenticati... forse perche usano cached credential..)
Il primo test che ti consiglio è di verificare che il dns (10.0.0.8)
contenga i corretti record SRV.
Apri la console dns (10.0.0.8) e verifica che sotto
DOMINIO.IT->_sites->NomeSite(prob. Default-First-Site-Name)->_tcp
siano presenti almeno due(uno deve puntare ad un dc e l'altro deve
puntare all'altro) per ognuno di questi SRV record: _kerberos,_ldap,
se per il record _gc ne trovi solo uno, promuovi a "global catalog"
anche l'altro DC (il 10.0.0.8).
Poi lancia un dcdiag ed un netdiag e verifica se taluni test non passano.
Effettivamente era proprio una cosa banale ed il server 10.0.0.8 non
era un Global Catalog. (o meglio in realtà era selezionata l'opzione
ed infatti mi sembrava di averlo fatto a suo tempo, ma nel DNS non
esisteva il record _gc relativo). Non so cosa possa essere
successo... Comunque ho rimosso l'opzione e l'ho rimessa. Dopo 5
minuti tutto è ricomparso nel DNS.
Grazie. Luca.
Bene!

Ciao Luca! :-)
--
Stefano FIO - ***@securityarchitect.it
MCSE Security Windows Server NT/2K/2K3
MCT - CWNA - CCNA - CCDA
------------------------------------------------------------------
-This posting is provided "AS IS" with no warranties,
and confers no rights
- Le informazioni fornite in questo messaggio sono fornite
senza vincolo di garanzia e senza responsabilità alcuna
------------------------------------------------------------------
Continua a leggere su narkive:
Loading...