Discussione:
Aiuto! Sono disperato! Problema con Windows 2003 SBS Server
(troppo vecchio per rispondere)
gFelicE
2005-03-20 19:06:46 UTC
Permalink
Ho un server che da settembre (si, si settembre 2004, non è un errore di
battitura!!!) mi sta facendo patire le pene dell'inferno.
Premetto: pur non reputandomi esperto, ho già installato e configurato
almeno una decina di server con lo stesso S/O ed una 20ina con 2000 SBS
Server, per cui, non sono nemmeno uno sprovveduto completo!
Errori inspiegabili che compiaiono improvvisamente e, come sono apparsi
spariscono.
Dopo aver cambiato tutto l'hardware possibile, alla fine mi sono arreso
ed ho deciso di sacrificare il fine settimana a reinstallare tutto
daccapo, ricreare il dominio ecc. ecc.
Tutto bene fino a quando non ho avuto la splendida idea di installare il
SP1 di Exchange Server 2003.
La procedura termina, ma alla fine mi viene segnalato un errore e
compare una crocetta rossa su "strumenti di comunicazione di Exchange "
(o simile, susatemi ma sto andando a memoria)
Sembra che tutto funzioni correttamente, ma invece non funziona la posta
in uscita, ne' viene recapitato alcun messaggio alle cassette postali
degli utenti.
Il connettore POP3 fa il suo lavoro (ogni 15 min. scarica la posta dal
server dell'ISP) ma poi questa non arriva alle cassette postali degli
utenti.
Idem il server fax: riceve il fax, lo archivia, lo inoltra per email, ma
l'email non arriva da nessuna parte.
I messaggi restano nella coda SMTP.
Ovviemente il server cerca di mandare un avviso di mancato recapito
all'amministratore del sistema, ma anche quell'avviso ovviamente non
giunge a destinazione.
Ovviamente la colpa è di quel maledettissimo errore nell'installazione
del SP1, ho pensato io.
Quale può essere il motivo per cui i vari messaggi (posta interna
compresa) non vengono recapitati?
Ah, dimenticavo!
Ovviamente nel registro degli eventi nemmeno l'ombra di un errore che
possa mettermi sulla buona strada!
Per intenderci il servizio POP3 e SMTP sono regolarmente avviati e così
pure Microsoft Exchange Information Store.
Prima di disinstallare Exchange Server per reinstallarlo daccapo, cosa
posso verificare?
Vi prego aiutatemi, sto per avere una crisi di nervi....

Giulio
Stefano Fio
2005-03-21 08:31:52 UTC
Permalink
Post by gFelicE
Ho un server che da settembre (si, si settembre 2004, non è un errore
di battitura!!!) mi sta facendo patire le pene dell'inferno.
Premetto: pur non reputandomi esperto, ho già installato e configurato
almeno una decina di server con lo stesso S/O ed una 20ina con 2000
SBS Server, per cui, non sono nemmeno uno sprovveduto completo!
Errori inspiegabili che compiaiono improvvisamente e, come sono
apparsi spariscono.
Dopo aver cambiato tutto l'hardware possibile, alla fine mi sono
arreso ed ho deciso di sacrificare il fine settimana a reinstallare
tutto daccapo, ricreare il dominio ecc. ecc.
Tutto bene fino a quando non ho avuto la splendida idea di installare
il SP1 di Exchange Server 2003.
La procedura termina, ma alla fine mi viene segnalato un errore e
compare una crocetta rossa su "strumenti di comunicazione di Exchange
" (o simile, susatemi ma sto andando a memoria)
Sembra che tutto funzioni correttamente, ma invece non funziona la
posta in uscita, ne' viene recapitato alcun messaggio alle cassette
postali degli utenti.
Il connettore POP3 fa il suo lavoro (ogni 15 min. scarica la posta dal
server dell'ISP) ma poi questa non arriva alle cassette postali degli
utenti.
Idem il server fax: riceve il fax, lo archivia, lo inoltra per email,
ma l'email non arriva da nessuna parte.
I messaggi restano nella coda SMTP.
Ovviemente il server cerca di mandare un avviso di mancato recapito
all'amministratore del sistema, ma anche quell'avviso ovviamente non
giunge a destinazione.
Ovviamente la colpa è di quel maledettissimo errore nell'installazione
del SP1, ho pensato io.
Quale può essere il motivo per cui i vari messaggi (posta interna
compresa) non vengono recapitati?
Ah, dimenticavo!
Ovviamente nel registro degli eventi nemmeno l'ombra di un errore che
possa mettermi sulla buona strada!
Per intenderci il servizio POP3 e SMTP sono regolarmente avviati e
così pure Microsoft Exchange Information Store.
Prima di disinstallare Exchange Server per reinstallarlo daccapo, cosa
posso verificare?
Vi prego aiutatemi, sto per avere una crisi di nervi....
Giulio
Tò:
http://support.microsoft.com/?kbid=827214 (questa dovrebbe risolvere!)

http://support.microsoft.com/default.aspx?scid=kb;en-us;872963

Ciao!
--
Stefano FIO - ***@securityarchitect.it
MCSE Security Windows Server 2K/2K3
MCT - CWNA
------------------------------------------------------------------
-This posting is provided "AS IS" with no warranties,
and confers no rights
- Le informazioni fornite in questo messaggio sono fornite
senza vincolo di garanzia e senza responsabilità alcuna
------------------------------------------------------------------
gFelicE
2005-03-21 08:50:24 UTC
Permalink
il Mon, 21 Mar 2005 09:31:52 +0100, "Stefano Fio"
<***@tiscali.it> scrive:

...
|>
|>Tò:
|>http://support.microsoft.com/?kbid=827214 (questa dovrebbe risolvere!)
|>
|>http://support.microsoft.com/default.aspx?scid=kb;en-us;872963
|>
|>Ciao!

Grazie Stefano.
Ho pero' timore ad applicare i correttivi indicati negli articoli hce mi
hai gentilmente indicato in quanto sembrano specifici per gli errori
7031, 7034 e 1000 che io invece non mi ritrovo nel log di sistema.
Ciao
Stefano Fio
2005-03-21 09:00:30 UTC
Permalink
Post by gFelicE
il Mon, 21 Mar 2005 09:31:52 +0100, "Stefano Fio"
...
Post by Stefano Fio
http://support.microsoft.com/?kbid=827214 (questa dovrebbe
risolvere!)
http://support.microsoft.com/default.aspx?scid=kb;en-us;872963
Ciao!
Grazie Stefano.
Ho pero' timore ad applicare i correttivi indicati negli articoli hce
mi hai gentilmente indicato in quanto sembrano specifici per gli
errori 7031, 7034 e 1000 che io invece non mi ritrovo nel log di
sistema.
Ciao
ok. guarda quì: http://support.microsoft.com/?kbid=285116

Ciao!
--
Stefano FIO - ***@securityarchitect.it
MCSE Security Windows Server 2K/2K3
MCT - CWNA
------------------------------------------------------------------
-This posting is provided "AS IS" with no warranties,
and confers no rights
- Le informazioni fornite in questo messaggio sono fornite
senza vincolo di garanzia e senza responsabilità alcuna
------------------------------------------------------------------
gFelicE
2005-03-21 09:18:36 UTC
Permalink
il Mon, 21 Mar 2005 10:00:30 +0100, "Stefano Fio"
<***@tiscali.it> scrive:

|>gFelicE wrote:
|>> il Mon, 21 Mar 2005 09:31:52 +0100, "Stefano Fio"
|>> <***@tiscali.it> scrive:
|>>
|>> ...
|>>>>
|>>>> Tò:
|>>>> http://support.microsoft.com/?kbid=827214 (questa dovrebbe
|>>>> risolvere!)
|>>>>
|>>>> http://support.microsoft.com/default.aspx?scid=kb;en-us;872963
|>>>>
|>>>> Ciao!
|>>
|>> Grazie Stefano.
|>> Ho pero' timore ad applicare i correttivi indicati negli articoli hce
|>> mi hai gentilmente indicato in quanto sembrano specifici per gli
|>> errori 7031, 7034 e 1000 che io invece non mi ritrovo nel log di
|>> sistema.
|>> Ciao
|>
|>
|>ok. guarda quì: http://support.microsoft.com/?kbid=285116
|>
|>Ciao!

Grazie, ma già visto, fatte tutte le verifiche ma risolto NIENTE!
Sai dove posso trovare un negozio di lamette?
Stefano Fio
2005-03-21 09:44:42 UTC
Permalink
Post by gFelicE
il Mon, 21 Mar 2005 10:00:30 +0100, "Stefano Fio"
Post by Stefano Fio
Post by gFelicE
il Mon, 21 Mar 2005 09:31:52 +0100, "Stefano Fio"
...
Post by Stefano Fio
http://support.microsoft.com/?kbid=827214 (questa dovrebbe risolvere!)
http://support.microsoft.com/default.aspx?scid=kb;en-us;872963
Ciao!
Grazie Stefano.
Ho pero' timore ad applicare i correttivi indicati negli articoli
hce mi hai gentilmente indicato in quanto sembrano specifici per
gli errori 7031, 7034 e 1000 che io invece non mi ritrovo nel log
di sistema.
Ciao
ok. guarda quì: http://support.microsoft.com/?kbid=285116
Ciao!
Grazie, ma già visto, fatte tutte le verifiche ma risolto NIENTE!
Sai dove posso trovare un negozio di lamette?
mmmh, ALLORA è GUERRA!!! ;-)
Aspetta per le lamette.. ti avviso io!!! ;-)

Ora opprofondiamo la cosa...
--
Stefano FIO - ***@securityarchitect.it
MCSE Security Windows Server 2K/2K3
MCT - CWNA
------------------------------------------------------------------
-This posting is provided "AS IS" with no warranties,
and confers no rights
- Le informazioni fornite in questo messaggio sono fornite
senza vincolo di garanzia e senza responsabilità alcuna
------------------------------------------------------------------
Stefano Fio
2005-03-21 10:12:26 UTC
Permalink
Post by gFelicE
il Mon, 21 Mar 2005 10:00:30 +0100, "Stefano Fio"
Post by Stefano Fio
Post by gFelicE
il Mon, 21 Mar 2005 09:31:52 +0100, "Stefano Fio"
...
Post by Stefano Fio
http://support.microsoft.com/?kbid=827214 (questa dovrebbe risolvere!)
http://support.microsoft.com/default.aspx?scid=kb;en-us;872963
Ciao!
Grazie Stefano.
Ho pero' timore ad applicare i correttivi indicati negli articoli
hce mi hai gentilmente indicato in quanto sembrano specifici per
gli errori 7031, 7034 e 1000 che io invece non mi ritrovo nel log
di sistema.
Ciao
ok. guarda quì: http://support.microsoft.com/?kbid=285116
Ciao!
Grazie, ma già visto, fatte tutte le verifiche ma risolto NIENTE!
Sai dove posso trovare un negozio di lamette?
Questo l'hai visto:
http://support.microsoft.com/kb/q290105/ ??

Cmq, penso che il tuo problema nato dopo la sp1 sia un problme di rights
(problemi soliti dopo le sp!)

Prova a seguire questi steps:

_______________________
CAUSE
The Services string type value located in the following registry key is
missing
or inaccessible:

HKEY LOCAL MACHINE\Software\Microsoft\Exchange\Setup



RESOLUTION
WARNING: Using Registry Editor incorrectly can cause serious problems
that may
require you to reinstall your operating system. Microsoft cannot
guarantee that
problems resulting from the incorrect use of Registry Editor can be
solved. Use
Registry Editor at your own risk.

For information about how to edit the registry, view the "Changing Keys
and
Values" Help topic in Registry Editor (Regedit.exe) or the "Add and
Delete
Information in the Registry" and "Edit Registry Data" Help topics in
Regedt32.exe. Note that you should back up the registry before you edit
it. If
you are running Windows NT ,Windows 2000, Windows 2003 , you should also
update your
Emergency
Repair Disk (ERD).
If the value is missing, you need to restore the following original
values to the
registry:

Value name: Services
Value type: String
Value: Path to Exchange 2003 installation root

For example, if Exchange 2003 was installed in the C:\Exchsrvr folder,
the path
is:
C:\Exchsrvr
If the value is present in the correct key, check the permission setting
on the
registry key. Use Regedt32 to check the permission setting of the key.
Get the service account of the information store. To do so:


In Control Panel, double-click Administrative Tools, and then
double-click
Services.


Locate the Microsoft Exchange Information Store service.


Double-click the service to open its properties.


Note the account name in the Log on tab. By default it should be Local
System
account.


Start Regedt32, and locate the following registry key:


HKEY LOCAL MACHINE\Software\Microsoft\Exchange\Setup
Use the Permission option under the Security tab to check the permission
setting
on this key. Make sure System is in the list with Full Control
permissions if the
service account is Local System. If you are not using Local System as
the service
account, check the existence of the corresponding account in the list
and ensure
that it has Full Control permissions.

-------------------------
Fammi sapere se abbiamo vinto noi!

Ciao!
--
Stefano FIO - ***@securityarchitect.it
MCSE Security Windows Server 2K/2K3
MCT - CWNA
------------------------------------------------------------------
-This posting is provided "AS IS" with no warranties,
and confers no rights
- Le informazioni fornite in questo messaggio sono fornite
senza vincolo di garanzia e senza responsabilità alcuna
------------------------------------------------------------------
gFelicE
2005-03-21 11:14:47 UTC
Permalink
il Mon, 21 Mar 2005 11:12:26 +0100, "Stefano Fio"
<***@tiscali.it> scrive:

...
|>Fammi sapere se abbiamo vinto noi!
|>
|>Ciao!

Alla fine ho installato l'hotfix che mi hai consigliato e tutto è
tornato a funzionare.
Grazie
Le lamette le tengo comunque per un altro problema....(vedi aposito
thread)
Ciao e grazie sei stato utilissimo.
Stefano Fio
2005-03-21 11:21:16 UTC
Permalink
Post by gFelicE
il Mon, 21 Mar 2005 11:12:26 +0100, "Stefano Fio"
...
Post by Stefano Fio
Fammi sapere se abbiamo vinto noi!
Ciao!
Alla fine ho installato l'hotfix che mi hai consigliato e tutto è
tornato a funzionare.
Hai Visto!! :-D
Post by gFelicE
Grazie
Prego!
Post by gFelicE
Le lamette le tengo comunque per un altro problema....(vedi aposito
thread)
Ciao e grazie sei stato utilissimo.
Ne sono felice.
Ciao!
--
Stefano FIO - ***@securityarchitect.it
MCSE Security Windows Server 2K/2K3
MCT - CWNA
------------------------------------------------------------------
-This posting is provided "AS IS" with no warranties,
and confers no rights
- Le informazioni fornite in questo messaggio sono fornite
senza vincolo di garanzia e senza responsabilità alcuna
------------------------------------------------------------------
gFelicE
2005-03-21 08:43:20 UTC
Permalink
il Sun, 20 Mar 2005 19:06:46 GMT, gFelicE <***@hotmail.com> scrive:
...
|>Ah, dimenticavo!
|>Ovviamente nel registro degli eventi nemmeno l'ombra di un errore che
|>possa mettermi sulla buona strada!
...

Correzione.
Ora compare questo errore:
ID evento: 9542
Origine: MSExchangeIS
Inizializzazione interfaccia esterna SMTP non riuscita. Errore:
ecVersioneMismatch-MAPI_E_VERSION.

Purtroppo non trovo info riguardo a questo specifico errore.
Ho trovato qualcosa solo per NNTP.
Chi mi puo' aiutare a far luce sul mistero?
Grazie
gFelicE
2005-03-21 08:46:14 UTC
Permalink
il Mon, 21 Mar 2005 08:43:20 GMT, gFelicE <***@hotmail.com> scrive:
...
|>Correzione.
|>Ora compare questo errore:
|>ID evento: 9542
|>Origine: MSExchangeIS
|>Inizializzazione interfaccia esterna SMTP non riuscita. Errore:
|>ecVersioneMismatch-MAPI_E_VERSION.
...
Aggiungo che compare lo stesso errore anche per l'interfaccia esterna
WIN32.
Guarda caso, sono entrambe le interfacce su cui viene segnalato l'errore
in fase di installazione del SP1 di Exchange Server 2003.
...
Ciao
Stefano Fio
2005-03-21 08:47:47 UTC
Permalink
scrive: ...
Post by gFelicE
Ah, dimenticavo!
Ovviamente nel registro degli eventi nemmeno l'ombra di un errore
che possa mettermi sulla buona strada!
...
Correzione.
ID evento: 9542
Origine: MSExchangeIS
ecVersioneMismatch-MAPI_E_VERSION.
Purtroppo non trovo info riguardo a questo specifico errore.
Ho trovato qualcosa solo per NNTP.
Chi mi puo' aiutare a far luce sul mistero?
Grazie
Installa il fix che ti ho postato precedentemente.

Ciao.
--
Stefano FIO - ***@securityarchitect.it
MCSE Security Windows Server 2K/2K3
MCT - CWNA
------------------------------------------------------------------
-This posting is provided "AS IS" with no warranties,
and confers no rights
- Le informazioni fornite in questo messaggio sono fornite
senza vincolo di garanzia e senza responsabilità alcuna
------------------------------------------------------------------
gFelicE
2005-03-21 11:12:35 UTC
Permalink
il Mon, 21 Mar 2005 09:47:47 +0100, "Stefano Fio"
<***@tiscali.it> scrive:

...
|>
|>Installa il fix che ti ho postato precedentemente.
|>
|>Ciao.

Ho fatto come mi hai detto ed ha funzionato!!!!!!
Grazie mi hai salvato la vita.
Ciao
Stefano Fio
2005-03-21 11:20:23 UTC
Permalink
Post by gFelicE
il Mon, 21 Mar 2005 09:47:47 +0100, "Stefano Fio"
...
Post by Stefano Fio
Installa il fix che ti ho postato precedentemente.
Ciao.
Ho fatto come mi hai detto ed ha funzionato!!!!!!
Grazie mi hai salvato la vita.
Beh si! visto che parlavi di lamette!!!! ;-) ;-) ;-)
Post by gFelicE
Ciao
Ciao gFelicE e buon lavoro! :-)
--
Stefano FIO - ***@securityarchitect.it
MCSE Security Windows Server 2K/2K3
MCT - CWNA
------------------------------------------------------------------
-This posting is provided "AS IS" with no warranties,
and confers no rights
- Le informazioni fornite in questo messaggio sono fornite
senza vincolo di garanzia e senza responsabilità alcuna
------------------------------------------------------------------
Continua a leggere su narkive:
Loading...