Discussione:
Riavvio Server 2003
(troppo vecchio per rispondere)
Daniele
2005-06-01 18:06:18 UTC
Permalink
Ciao a tutti, ho da qualche giorno installato un server con 2003 Server
Enterprise Edition su un dual Xeon con 8GB di Ram.
Oggi il cliente mi ha chiamato perchè la macchina si è resettata da sola.
Guardando nell'event viewer mi veniva segnalato il seguente avviso:

Tipo evento: Avviso
Origine evento: USER32
Categoria evento: Nessuno
ID evento: 1076
Data: 01/06/2005
Ora: 15.37.02
Utente: utente
Computer: SERVER
Descrizione:
La causa indicata dall'utente per l'ultimo riavvio imprevisto del computer
è: System Failure: Stop error
Causa non grave: 0x805000f
Commento: ....

In seguito a questo mi sono avventurato nel debug del dump di memoria
generato nell'occasione e,pur non capendo molto, ho letto questo:

Probably caused by : ntkrnlpa.exe ( nt!FsRtlNotifyUpdateBuffer+8f )

Quello che mi domando è se questo può essere in qualche modo collegato
all'estensione /PAE che ho aggiunto al boot.ini per gestire gli 8GB di ram.

Ciao

Daniele
Rossano Orlandini [MVP]
2005-06-01 18:41:03 UTC
Permalink
On Wed, 1 Jun 2005 20:06:18 +0200, "Daniele"
<***@mfbnet.it> wrote:

[CUT]
Post by Daniele
In seguito a questo mi sono avventurato nel debug del dump di memoria
Probably caused by : ntkrnlpa.exe ( nt!FsRtlNotifyUpdateBuffer+8f )
Quello che mi domando è se questo può essere in qualche modo collegato
all'estensione /PAE che ho aggiunto al boot.ini per gestire gli 8GB di ram.
Abilitando l'estensione /PAE il sistema operativo carica un kernel
diverso da Ntoskrnl (pescandolo dal file Driver.cab nella cartella
I386). Per sistemi monoprocessore il file si chiama ora Ntkrnlpa.exe,
mentre per sistemi multiprocessore si chiama Ntkrpamp.exe.

Dunque è strano che sul tuo dual Xeon si faccia riferimento al file
Ntlrnlpa.exe. Che server è? Di marca? Assemblato? Windows vede
correttamente i due processori? Tutti i driver di sistema compreso il
firmware BIOS della motherboard sono aggiornati? E' per caso
installato l'SP1 di Windows 2003? La macchina è aggiornata con tutte
le hotfix di sicurezza di Windowsupdate?
--
Rossano Orlandini
MCSE MCSA MVP - Windows Server
Daniele
2005-06-01 18:50:05 UTC
Permalink
Intanto ti ringrazio per la tempestività e vado a rispondere alle tue
domande:
- il server è assemblato (da me) su un motherboard asus PR-DLS533 bios
aggiornato.
- c'è anche installato un controller RAID lsi logic Megaraid 320-1 con
firmware aggiornati e driver per 2003 server 32bit
- il server vede correttamente i 2 processori nell'elenco periferiche
- SP1 installato e installati anche tutti gli aggiornamenti di protezione

Non ho installato altri driver perchè tutto l'hardware è stato rilevato
correttamente dal s.o. e ho preferito non toccare nulla.

Ciao

Daniele
Post by Rossano Orlandini [MVP]
On Wed, 1 Jun 2005 20:06:18 +0200, "Daniele"
[CUT]
Post by Daniele
In seguito a questo mi sono avventurato nel debug del dump di memoria
Probably caused by : ntkrnlpa.exe ( nt!FsRtlNotifyUpdateBuffer+8f )
Quello che mi domando è se questo può essere in qualche modo collegato
all'estensione /PAE che ho aggiunto al boot.ini per gestire gli 8GB di ram.
Abilitando l'estensione /PAE il sistema operativo carica un kernel
diverso da Ntoskrnl (pescandolo dal file Driver.cab nella cartella
I386). Per sistemi monoprocessore il file si chiama ora Ntkrnlpa.exe,
mentre per sistemi multiprocessore si chiama Ntkrpamp.exe.
Dunque è strano che sul tuo dual Xeon si faccia riferimento al file
Ntlrnlpa.exe. Che server è? Di marca? Assemblato? Windows vede
correttamente i due processori? Tutti i driver di sistema compreso il
firmware BIOS della motherboard sono aggiornati? E' per caso
installato l'SP1 di Windows 2003? La macchina è aggiornata con tutte
le hotfix di sicurezza di Windowsupdate?
--
Rossano Orlandini
MCSE MCSA MVP - Windows Server
Rossano Orlandini [MVP]
2005-06-01 22:08:52 UTC
Permalink
On Wed, 1 Jun 2005 20:50:05 +0200, "Daniele"
Post by Daniele
Intanto ti ringrazio per la tempestività e vado a rispondere alle tue
- il server è assemblato (da me) su un motherboard asus PR-DLS533 bios
aggiornato.
- c'è anche installato un controller RAID lsi logic Megaraid 320-1 con
firmware aggiornati e driver per 2003 server 32bit
- il server vede correttamente i 2 processori nell'elenco periferiche
- SP1 installato e installati anche tutti gli aggiornamenti di protezione
Non ho installato altri driver perchè tutto l'hardware è stato rilevato
correttamente dal s.o. e ho preferito non toccare nulla.
Ho notato che anche 2 mesi fa (per la precisione il 9 Marzo) avevi
scritto per un problema analogo (riavvio casuale del sistema) su una
configurazione hardware pressoché identica, meno RAM però e sistema
operativo Windows 2003 Standard. Immagino non si tratti dello stesso
server, visto che dici che questo l'hai installato solo da qualche
giorno. Secondo me ci sono dei componenti difettosi o incompatibili in
entrambi i casi, forse la stessa marca di RAM, forse i driver... io
controllerei e ri-testerei il tutto, una simile configurazione sta
dando parecchia instabilità.
--
Rossano Orlandini
MCSE MCSA MVP - Windows Server
g***@gmail.com
2005-06-03 18:36:26 UTC
Permalink
In effetti si, avevo avuto lo stesso problema su un altro server
qualche mese fa.
In quel caso ho dovuto fare una macchina identica al cliente e da quel
momento non si è più verificato il problema.
Adesso provo a seguire il tuo consiglio.
Grazie di tutto.

Ciao

Daniele

Daniele
2005-06-01 19:06:58 UTC
Permalink
Windows Server 2003 Kernel Version 3790 (Service Pack 1) MP (4 procs) Free
x86 compatible
Product: LanManNt, suite: Enterprise TerminalServer SingleUserTS

...se ti può essere d'aiuto...
Post by Rossano Orlandini [MVP]
On Wed, 1 Jun 2005 20:06:18 +0200, "Daniele"
[CUT]
Post by Daniele
In seguito a questo mi sono avventurato nel debug del dump di memoria
Probably caused by : ntkrnlpa.exe ( nt!FsRtlNotifyUpdateBuffer+8f )
Quello che mi domando è se questo può essere in qualche modo collegato
all'estensione /PAE che ho aggiunto al boot.ini per gestire gli 8GB di ram.
Abilitando l'estensione /PAE il sistema operativo carica un kernel
diverso da Ntoskrnl (pescandolo dal file Driver.cab nella cartella
I386). Per sistemi monoprocessore il file si chiama ora Ntkrnlpa.exe,
mentre per sistemi multiprocessore si chiama Ntkrpamp.exe.
Dunque è strano che sul tuo dual Xeon si faccia riferimento al file
Ntlrnlpa.exe. Che server è? Di marca? Assemblato? Windows vede
correttamente i due processori? Tutti i driver di sistema compreso il
firmware BIOS della motherboard sono aggiornati? E' per caso
installato l'SP1 di Windows 2003? La macchina è aggiornata con tutte
le hotfix di sicurezza di Windowsupdate?
--
Rossano Orlandini
MCSE MCSA MVP - Windows Server
Stefano Fio
2005-06-01 20:45:48 UTC
Permalink
"Daniele" <***@mfbnet.it> ha scritto nel messaggio news:rOmne.4592$***@tornado.fastwebnet.it...
[CUT]
Post by Daniele
Probably caused by : ntkrnlpa.exe ( nt!FsRtlNotifyUpdateBuffer+8f )
Quello che mi domando è se questo può essere in qualche modo collegato
all'estensione /PAE che ho aggiunto al boot.ini per gestire gli 8GB di ram.
Ciao
Daniele
Per ora mi sa che ti tocca disabilitare dal bios l'HT, è un problema
ricorrente relativo all'hardware che hai descritto.
Per xp c'è già la soluzione:
http://support.microsoft.com/default.aspx?id=817027
Per server 2003 arriverà presto.

Ciao.


--
Stefano FIO - ***@securityarchitect.it
MCSE Security Windows Server NT/2K/2K3
MCT - CWNA - CCNA - CCDA
------------------------------------------------------------------
-This posting is provided "AS IS" with no warranties,
and confers no rights
- Le informazioni fornite in questo messaggio sono fornite
senza vincolo di garanzia e senza responsabilità alcuna
------------------------------------------------------------------
Continua a leggere su narkive:
Loading...