Discussione:
dominio 2000 server e nuovo server 2003
(troppo vecchio per rispondere)
spackmeier
2010-03-26 09:28:01 UTC
Permalink
Ho un dominio 2000 server sp4 e ho aggiunto un server 2003 r2 che andrà a
sostituire il server "vecchio" con win 2000

Ho attivato praticamente tutti i servizi, DNS, AD, WINS, DHCP e in siti e
servizi ora sono entrambi catalogo globale. Ho dovuto fare un passo indietro
in quanto avevo gia anche eletto il 2003 a Master delle operazioni da AD...
ma ho dovuto mettere come Master il vecchio 2000.

Questo perchè ho notato che con il 2003 la cartella sysvol e netlogon non
sono condivise.

La replica nel log del server 2003 non ha piu errori (avevo ID13565 e 13508)
ma non si replica nulla. Il server 2000 non ha errori nel log. Ora sto
provando a condividere la cartella "a mano".

Ho visto anche un aritcolo il 315457, lo devo applicare? E' una operazione
che posso fare tranquillamente oppure può causare problemi agli utenti?

Se condivido a mano le cartelle il problema potrebbe risolversi?

Grazie.
Fabrizio Volpe
2010-03-26 10:01:00 UTC
Permalink
Ciao.
Scusami, ma nella lista non ho visto
ADPrep /forestprep
ADPrep /domainprep
li hai lanciati correttamente ?

http://www.petri.co.il/windows_2003_adprep.htm
--
Fabrizio Volpe

MCSE (NT4) (2000) (2003) , MCSA (2003) , MCTS (SQL 2005) (Exchange 2007) (Windows 2008)
Fortinet Certified Network Security Administrator (FCNSA)
spackmeier
2010-03-26 12:52:01 UTC
Permalink
nessuna idea?

Grazie ragazzi.
Ora sto facendo altri controlli e senza la replica il mio 2003 non è a tutti
gli effetti un DC funzionante...
Help please...
Grazie.
Ho guardato il link e se non ricordo male dovrei aver fatto tutto il
procedimento.
Nel caso, nella situazione in cui sono ora, posso rilanciare
ADPrep /forestprep
ADPrep /domainprep
sul server 2003?
Se si come procedo poi?
Grazie.
Post by Fabrizio Volpe
Ciao.
Scusami, ma nella lista non ho visto
ADPrep /forestprep
ADPrep /domainprep
li hai lanciati correttamente ?
http://www.petri.co.il/windows_2003_adprep.htm
--
Fabrizio Volpe
MCSE (NT4) (2000) (2003) , MCSA (2003) , MCTS (SQL 2005) (Exchange 2007) (Windows 2008)
Fortinet Certified Network Security Administrator (FCNSA)
.
Fabrizio Volpe
2010-03-26 13:37:25 UTC
Permalink
Post by spackmeier
nessuna idea?
Grazie ragazzi.
Qualche idea mi può venire, se rispondi alla prima domanda :
hai lanciato ADPrep /forestprep e ADPrep /domainprep sulla macchina
2000 con utenti aventi permessi adeguati PRIMA di aggiungere il DC
2003 ?
--
Fabrizio Volpe

MCSE (NT4) (2000) (2003) , MCSA (2003) , MCTS (SQL 2005) (Exchange 2007) (Windows 2008)
Fortinet Certified Network Security Administrator (FCNSA)
spackmeier
2010-03-26 14:35:01 UTC
Permalink
Si si l'ho fatto.

Adesso ho eseguito l'articolo 315457 e replica senza errori!!!

Ho eletto da AD il master (ovviamete il 2003 server) e poi ho lanciato un
netdom query fsmo e mi rende per tutto il server 2003 mentre Schema Owner è
ancora il server 2000.

Esattamente Schema owner cosa indica? Come faccio diventare il 2003 lo
schema owner?

In ultimo dovrò rimuovere il 2000 dal dominio, potete per favore indicarmi i
passaggi corretti per evitare problemi?

Grazie mille.
Post by Fabrizio Volpe
Post by spackmeier
nessuna idea?
Grazie ragazzi.
hai lanciato ADPrep /forestprep e ADPrep /domainprep sulla macchina
2000 con utenti aventi permessi adeguati PRIMA di aggiungere il DC
2003 ?
--
Fabrizio Volpe
MCSE (NT4) (2000) (2003) , MCSA (2003) , MCTS (SQL 2005) (Exchange 2007) (Windows 2008)
Fortinet Certified Network Security Administrator (FCNSA)
.
Fabrizio Volpe
2010-03-26 15:01:55 UTC
Permalink
Per trasferire tutti gli FSMO segui quest'articolo.

http://www.petri.co.il/transferring_fsmo_roles.htm

A quel punto, modifica tutti i clients in modo da usare 2003 come DNS
e sei a posto.
--
Fabrizio Volpe

MCSE (NT4) (2000) (2003) , MCSA (2003) , MCTS (SQL 2005) (Exchange 2007) (Windows 2008)
Fortinet Certified Network Security Administrator (FCNSA)
spackmeier
2010-03-31 11:51:03 UTC
Permalink
Spero che questa discussione non sia chiusa altrimenti posterò una nuova
domanda.

p.s. Metto sempre la "notifica in caso di risposte" ma non mi arriva mai
nulla.
grazie
Yes perfetto!
Ora ho controllato e mi sono usciti 2 errorini ma non so quanto preoccuparmi.
Il primo è nel servizio di replica file ed è uscito solo 3 volte, una al
giorno e sempre alla stessa ora. Enento numero 13562 che riporta
"segue un riepilogo degli avvisi e degli errori incontrati dal servizio di
replica file durante il polling del controller di dominio
mionuovoserver.dominio.locale per le informazioni di configurazione
dell'insieme di repliche del servizio di replica file"
Origine: Ntfrs utente N/D Tipo: avviso
Solo questi 3 poi il log è pulito.
In sistema invece mi è uscito qualche errore 1003, circa ogni mezzora, con
"impossibile ottenere le informazioni di mapping da Mapping nomi utente.
Verrà eseguito un ulteriore tentativo da 30 minuti"
Oltre a questo niente di anomalo, il server funziona regolare e non ha altre
segnalazioni nel log.
Mi devo preoccupare o sono solo delle segnalazioni?
Inoltre ho letto un pochino il file che mi chiedi, ntdsutil e gli altri
comandi sono nel toolkit di 2000? Perchè se è così nel cd del box non le
trovo e non trovo la possibilità di scaricarli. Inoltre il mio server 2003 è
gia stato elevato a controller principale tramite le AD come master
"Ho eletto da AD il master (ovviamete il 2003 server) e poi ho lanciato un
netdom query fsmo e mi rende per tutto il server 2003 mentre Schema Owner è
ancora il server 2000"
Esattamente lo schema owner cosa sarebbe e come lo posso trasferire? Questo
è ancora un ruolo del 2000...
Grazie mille per tutto.
Fabrizio Volpe
2010-03-31 12:56:42 UTC
Permalink
La discussione è ancora aperto ma vorrei sapere se hai seguito le
varie indicazioni fornite e con quale esito.
--
Fabrizio Volpe

MCSE (NT4) (2000) (2003) , MCSA (2003) , MCTS (SQL 2005) (Exchange 2007) (Windows 2008)
Fortinet Certified Network Security Administrator (FCNSA)
spackmeier
2010-03-31 14:40:01 UTC
Permalink
Ho fatto tutto tranne trasferire i ruoli con il metedo del link che mi hai
passato.

In pratica dopo aver sistemato la replica (vedi messaggi precedenti, ho
seguito un articolo microsoft) ho rasferito i rouli tramite AD facendo
diventare Master il 2003. Poi con il comando netdom query fsmo ho visto che
tutti i ruoli, tranne Schema Owner, sono del 2003 infatti tutti gli user si
loggano sul 2003 (li vedo nei logs del server). I servizi sono tutti
trasferiti sul 2003.

Quello che mi manca ora sono 3 cose:

- Cosè esattamente Schema Owner e come trasferire questo ruolo dal 2000 al
2003
- verificare le 2 segnalazioni nei log che ho postato
- la procedura corretta per rimuovere il 2000 dalla rete

I pc puntano gia come DNS al 2003. Ora non sono dal cliente anche perchè è
un po' lontano e ogni tanto mi collego in teleassistenza per verificare ma
sembra tutto in ordine e si lavora senza problemi.

Ah dimenticavo, dicevo che anche se metto il flag a "notifica in caso di
risposte" non mi arriva nessuna mail quindi potrei metterci molto a
rispondere.

Grazie!
Post by Fabrizio Volpe
La discussione è ancora aperto ma vorrei sapere se hai seguito le
varie indicazioni fornite e con quale esito.
--
Fabrizio Volpe
MCSE (NT4) (2000) (2003) , MCSA (2003) , MCTS (SQL 2005) (Exchange 2007) (Windows 2008)
Fortinet Certified Network Security Administrator (FCNSA)
.
spackmeier
2010-04-02 10:59:01 UTC
Permalink
Ho controllato oggi e i due errori sono sempre presenti, identici, il il 1003
ogni 30 minuti circa e il 13562 una volta al giorno.

Il resto sembra tutto ok, resto in attesa e ti ringrazio molto Fabrizio

Quello che mi manca ora sono 3 cose:

- Cosè esattamente Schema Owner e come trasferire questo ruolo dal 2000 al
2003
- verificare le 2 segnalazioni nei log che ho postato
- la procedura corretta per rimuovere il 2000 dalla rete

Grazie ancora.
Post by spackmeier
Ho fatto tutto tranne trasferire i ruoli con il metedo del link che mi hai
passato.
In pratica dopo aver sistemato la replica (vedi messaggi precedenti, ho
seguito un articolo microsoft) ho rasferito i rouli tramite AD facendo
diventare Master il 2003. Poi con il comando netdom query fsmo ho visto che
tutti i ruoli, tranne Schema Owner, sono del 2003 infatti tutti gli user si
loggano sul 2003 (li vedo nei logs del server). I servizi sono tutti
trasferiti sul 2003.
- Cosè esattamente Schema Owner e come trasferire questo ruolo dal 2000 al
2003
- verificare le 2 segnalazioni nei log che ho postato
- la procedura corretta per rimuovere il 2000 dalla rete
I pc puntano gia come DNS al 2003. Ora non sono dal cliente anche perchè è
un po' lontano e ogni tanto mi collego in teleassistenza per verificare ma
sembra tutto in ordine e si lavora senza problemi.
Ah dimenticavo, dicevo che anche se metto il flag a "notifica in caso di
risposte" non mi arriva nessuna mail quindi potrei metterci molto a
rispondere.
Grazie!
Post by Fabrizio Volpe
La discussione è ancora aperto ma vorrei sapere se hai seguito le
varie indicazioni fornite e con quale esito.
--
Fabrizio Volpe
MCSE (NT4) (2000) (2003) , MCSA (2003) , MCTS (SQL 2005) (Exchange 2007) (Windows 2008)
Fortinet Certified Network Security Administrator (FCNSA)
.
Fabrizio Volpe
2010-04-02 12:11:02 UTC
Permalink
Ciao.
Lo schema owner è l'unica macchina della foresta che detiene la
capacità di scrittura della struttura oggetti / attributi.

Puoi immaginare che in active directory siano definiti N attributi
(nome, cognome, telefono) da valorizzare e N oggetti che sono definiti
da un set di attributi (user , computer e così via).

Lo stesso attributo (nome, per esempio) può essere usato in più tipi
di oggetti.

In alcune situazioni (installazione di Exchange, ad esempio) lo schema
viene modificato per aggiungere oggetti e attributi e per modificare
il set di attributi di ogni oggetto.

Tale operazione può avvenire SOLO sullo schema owner.

Ovviamente ho semplificato al massimo, spero di rendere il concetto.

Detto questo, per spostare lo schema owner da interfaccia grafica,
devi registrare la dll schmmgmt.dll , aprire nella MMC la snap-in
schema e spostare il ruolo.

Vedi qui

http://support.microsoft.com/kb/255690


Rimozione del DC : de hai tolto dai client il puntamento DNS al server
2000 e hai attivato un G.C. sul nuovo DC, ti basta fare DCPROMO e
applicare un "demote" per il server 2000.
Fatto questo, al riavvio successivo, spostalo da dominio a workgroup e
hai finito.

P.S.
Se mi vengono i calli ai polpastrelli è colpa tua.
--
Fabrizio Volpe

MCSE (NT4) (2000) (2003) , MCSA (2003) , MCTS (SQL 2005) (Exchange 2007) (Windows 2008)
Fortinet Certified Network Security Administrator (FCNSA)
spackmeier
2010-04-14 14:28:11 UTC
Permalink
Ho mandato indicazioni ma non mi risponde piu nessuno, un moderatore?

Ho anche aperto una nuova discussione alla quale non ho ricevuto nessuna
risposta. La discussione ha lo stesso titolo ma con 2 finale ed è del 9/04

Grazie ancora.
Post by Fabrizio Volpe
La discussione è ancora aperto ma vorrei sapere se hai seguito le
varie indicazioni fornite e con quale esito.
--
Fabrizio Volpe
MCSE (NT4) (2000) (2003) , MCSA (2003) , MCTS (SQL 2005) (Exchange 2007) (Windows 2008)
Fortinet Certified Network Security Administrator (FCNSA)
.
Fabrizio Volpe
2010-04-16 08:09:52 UTC
Permalink
Post by spackmeier
Ho mandato indicazioni ma non mi risponde piu nessuno, un moderatore?
Ho anche aperto una nuova discussione alla quale non ho ricevuto nessuna
risposta. La discussione ha lo stesso titolo ma con 2 finale ed è del 9/04
Grazie ancora.
Non vedo la discussione del 09/04

Non vedo i dati aggiuntivi.

A questo punto dovresti anche riassumermi il problema, visto che ci
siamo allontanati molto dalla richiesta iniziale.

Per finire no, non c'è moderatore, solo un gruppo di volenterosi che
cercano di aiutare dove possibile.

Trattandosi di "Gratis et amore Dei" non è male, te lo assicuro :-P
--
Fabrizio Volpe

MCSE (NT4) (2000) (2003) , MCSA (2003) , MCTS (SQL 2005) (Exchange 2007) (Windows 2008)
Fortinet Certified Network Security Administrator (FCNSA)
spackmeier
2010-05-19 12:31:01 UTC
Permalink
Non lo metto in dubbio anzi! Ringrazio per la pazienza!

Grazie.
Post by Fabrizio Volpe
Post by spackmeier
Ho mandato indicazioni ma non mi risponde piu nessuno, un moderatore?
Ho anche aperto una nuova discussione alla quale non ho ricevuto nessuna
risposta. La discussione ha lo stesso titolo ma con 2 finale ed è del 9/04
Grazie ancora.
Non vedo la discussione del 09/04
Non vedo i dati aggiuntivi.
A questo punto dovresti anche riassumermi il problema, visto che ci
siamo allontanati molto dalla richiesta iniziale.
Per finire no, non c'è moderatore, solo un gruppo di volenterosi che
cercano di aiutare dove possibile.
Trattandosi di "Gratis et amore Dei" non è male, te lo assicuro :-P
--
Fabrizio Volpe
MCSE (NT4) (2000) (2003) , MCSA (2003) , MCTS (SQL 2005) (Exchange 2007) (Windows 2008)
Fortinet Certified Network Security Administrator (FCNSA)
.
spackmeier
2010-03-26 10:07:01 UTC
Permalink
Mettendo a mano la condivisione non fa nulla.

La replica non viene eseguita ma lasciando il master il vecchio 2000 ora
posso entrare nelle GPO dal server 2003 e fare modifiche e il backup.

Ora devo solo sapere come procedere per impostare la replica correttamente
e, una volta ottenuta una cartella sysvol corretta con tutte le sottocartelle
correlate, rimuovere e sganciare il vecchio server.

Resto in attesa, vi ringrazio.

P.s.: scusate ma è 2 gg che litigo con il server e non so piu che
fare...grazie ancora!
Post by spackmeier
Ho un dominio 2000 server sp4 e ho aggiunto un server 2003 r2 che andrà a
sostituire il server "vecchio" con win 2000
Ho attivato praticamente tutti i servizi, DNS, AD, WINS, DHCP e in siti e
servizi ora sono entrambi catalogo globale. Ho dovuto fare un passo indietro
in quanto avevo gia anche eletto il 2003 a Master delle operazioni da AD...
ma ho dovuto mettere come Master il vecchio 2000.
Questo perchè ho notato che con il 2003 la cartella sysvol e netlogon non
sono condivise.
La replica nel log del server 2003 non ha piu errori (avevo ID13565 e 13508)
ma non si replica nulla. Il server 2000 non ha errori nel log. Ora sto
provando a condividere la cartella "a mano".
Ho visto anche un aritcolo il 315457, lo devo applicare? E' una operazione
che posso fare tranquillamente oppure può causare problemi agli utenti?
Se condivido a mano le cartelle il problema potrebbe risolversi?
Grazie.
Edoardo Benussi [MVP]
2010-03-26 12:28:24 UTC
Permalink
Post by spackmeier
Mettendo a mano la condivisione non fa nulla.
[cut]

e vorrei ben vedere!!!

ti spiace postare gli errori che trovi nel registro
eventi sia del win2k3 sia del win2k nelle sezioni
system, applications, ntfrs e directory services ?
--
Edoardo Benussi - ***@mvps.org
Microsoft® MVP - Most Valuable Professional
Management Infrastructure - Systems Administration
https://mvp.support.microsoft.com/Profile/Benussi
Continua a leggere su narkive:
Loading...