Discussione:
W2k server DNS & AD
(troppo vecchio per rispondere)
clayshin@hotmail.com
2003-11-05 14:53:38 UTC
Permalink
Un saluto a tutti
sto cercando di implementare un server con W2003 in un
dominio esistente (W2K) ma quando specifico il dominio che
deve contattare ricevo il seguente errore:

"Impossibile contattare un controller di dominio Active
directory per il dominio ******.com"

Ho provato ad eseguire un dcdiag sul DC (W2K) con il
seguente risultato:

********************************************
create the GUID manually DC Diagnosis
Performing initial setup:
Done gathering initial info.

Doing initial non skippeable tests

Testing server: ******\NTSERVER
Starting test: Connectivity
NTSERVER's server GUID DNS name could not be
resolved to an
IP address. Check the DNS server, DHCP, server
name, etc
Although the Guid DNS name
(c39f0739-b692-4046-8552-
1025922c27d8._msdcs.******.com) couldn't be
resolved, the server name (ntserver.******.com)
resolved to the IP
address (172.16.199.127) and was pingable. Check
that the IP address
is registered correctly with the DNS server.
......................... NTSERVER failed test
Connectivity

Doing primary tests

Testing server: ******\NTSERVER
Skipping all tests, because server NTSERVER is
not responding to directory service requests

Running enterprise tests on : ******.com
Starting test: Intersite
......................... ******.com passed test
Intersite
Starting test: FsmoCheck
......................... ******.com passed test
FsmoCheck
********************************************************

Credo che il problema sia sul DNS ma non riesco a
risolverlo, qualche aiuto ?
Grazie e saluti.
Edoardo Benussi
2003-11-05 15:07:21 UTC
Permalink
ma prima di questo tentativo
l'active directory sul win2k ti funzionava bene?
--
-------------------------------------
Edoardo Benussi
***@tin.it
-------------------------------------
a***@discussions.microsoft.com
2003-11-05 15:15:06 UTC
Permalink
Si, funzionava e funziona tutt'ora.
-----Messaggio originale---
ma prima di questo tentativo
l'active directory sul win2k ti funzionava bene?
--
-------------------------------------
Edoardo Benussi
-------------------------------------
.
Edoardo Benussi
2003-11-05 15:29:18 UTC
Permalink
puoi riportare la configurazione che hai messo
sulla scheda di rete del server novo win2k3?
--
-------------------------------------
Edoardo Benussi
***@tin.it
-------------------------------------
Lamberti Mario
2003-11-05 15:35:27 UTC
Permalink
Post by a***@discussions.microsoft.com
Si, funzionava e funziona tutt'ora.
Il servizio dns e installato sul domain controller? Gli aggiornamenti
dinamici sono abilitati? Al server 2003 hai assegnato l'ip del dns corretto?
a***@discussions.microsoft.com
2003-11-05 15:45:51 UTC
Permalink
Il servizio DNS è configurato sul DC integrato a AD gli
aggiornamenti dinamici sono abilitati la scheda del DC
punta a se stesso come DNS e il server 2003 che voglio
integrare ha come DNS primario il DC.
Sinceramente non sò più cosa controllare.
-----Messaggio originale---
Post by a***@discussions.microsoft.com
Si, funzionava e funziona tutt'ora.
Il servizio dns e installato sul domain controller? Gli
aggiornamenti
dinamici sono abilitati? Al server 2003 hai assegnato
l'ip del dns corretto?
.
Lamberti Mario
2003-11-05 16:09:06 UTC
Permalink
Post by a***@discussions.microsoft.com
Il servizio DNS è configurato sul DC integrato a AD gli
aggiornamenti dinamici sono abilitati la scheda del DC
punta a se stesso come DNS e il server 2003 che voglio >integrare ha come
DNS primario il DC.
Post by a***@discussions.microsoft.com
Sinceramente non sò più cosa controllare.
Da come leggo sembra configurato bene scusa la banalità della domanda ma dal
server 2003 riesci a pingare il dc 2000 e viceversa?
a***@discussions.microsoft.com
2003-11-05 17:11:17 UTC
Permalink
Sissignore.
Addirittura Win2003 mi elenca il dominio che mi interessa
tra i selezionabili ma quando procedo và in errore.
-----Messaggio originale---
Post by a***@discussions.microsoft.com
Il servizio DNS è configurato sul DC integrato a AD gli
aggiornamenti dinamici sono abilitati la scheda del DC
punta a se stesso come DNS e il server 2003 che voglio
integrare ha come
DNS primario il DC.
Post by a***@discussions.microsoft.com
Sinceramente non sò più cosa controllare.
Da come leggo sembra configurato bene scusa la banalità
della domanda ma dal
server 2003 riesci a pingare il dc 2000 e viceversa?
.
Memmo
2003-11-05 21:46:20 UTC
Permalink
Post by a***@discussions.microsoft.com
Sissignore.
Addirittura Win2003 mi elenca il dominio che mi interessa
tra i selezionabili ma quando procedo và in errore.
Puoi postare un "ipconfig /all" sia del server Windows 2003 che del
server che ospita il DNS?

Ciao
Memmo
a***@discussions.microsoft.com
2003-11-06 11:19:27 UTC
Permalink
Ecco a voi

***********************************************************
****************
Windows 2003

Configurazione IP di Windows

Nome host . . . . . . . . . . . . . . : XXXXXXXSVR01
Suffisso DNS primario . . . . . . . . :
GruppoXXXXXX.local
Tipo nodo . . . . . . . . . . . . . . : Ibrido
Routing IP abilitato. . . . . . . . . : No
Proxy WINS abilitato . . . . . . . . : No
Elenco di ricerca suffissi DNS. . . . :
GruppoXXXXXX.local

Scheda Ethernet Connessione alla rete locale (LAN):

Suffisso DNS specifico per connessione:
Descrizione . . . . . . . . . . . . . : Compaq NC7760
Gigabit Server Adapter
Indirizzo fisico. . . . . . . . . . . : 00-0B-CD-CB-40-
70
DHCP abilitato. . . . . . . . . . . . : No
Indirizzo IP. . . . . . . . . . . . . : 172.16.199.130
Subnet mask . . . . . . . . . . . . . : 255.255.255.0
Gateway predefinito . . . . . . . . . : 172.16.199.100
Server DNS . . . . . . . . . . . . . : 172.16.199.127
Server WINS primario . . . . . . . . : 172.16.199.127


***********************************************************
****************

Windows 2000

Configurazione IP di Windows 2000

Nome host . . . . . . . . . . . : ntserver
Suffisso DNS primario . . . . . : xxxxxx.com
Tipo nodo . . . . . . . . . . . : Ibrido
IP Routing abilitato. . . . . . : Sì
WINS Proxy abilitato. . . . . . : No
Elenco di ricerca suffisso DNS . : xxxxxx.com

- Scheda Ethernet Connessione alla rete locale (LAN):

Suffisso DNS specifico connessione:
Descrizione . . . . . . . . . . : Controller
UTP/AUI incorporato PCI 1
0/100TX Netelligent
Indirizzo fisico. . . . . . . . : 00-50-8B-CA-14-
FF
DHCP abilitato . . . . . . . . . : No
Indirizzo IP. . . . . . . . . . . : 172.16.199.127
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Gateway predefinito . . . . . . . : 172.16.199.100
Server DNS. . . . . . . . . . . : 172.16.199.127
Server WINS primario . . . . . . : 172.16.199.127
Server WINS secondario . . . . . : 10.100.11.10

***********************************************************
***************
-----Messaggio originale---
Post by a***@discussions.microsoft.com
Sissignore.
Addirittura Win2003 mi elenca il dominio che mi
interessa
Post by a***@discussions.microsoft.com
tra i selezionabili ma quando procedo và in errore.
Puoi postare un "ipconfig /all" sia del server Windows
2003 che del
server che ospita il DNS?
Ciao
Memmo
.
Memmo
2003-11-06 11:29:38 UTC
Permalink
Post by a***@discussions.microsoft.com
Ecco a voi
***********************************************************
****************
Windows 2003
Configurazione IP di Windows
Nome host . . . . . . . . . . . . . . : XXXXXXXSVR01
GruppoXXXXXX.local
Tipo nodo . . . . . . . . . . . . . . : Ibrido
Routing IP abilitato. . . . . . . . . : No
Proxy WINS abilitato . . . . . . . . : No
GruppoXXXXXX.local
Descrizione . . . . . . . . . . . . . : Compaq NC7760
Gigabit Server Adapter
Indirizzo fisico. . . . . . . . . . . : 00-0B-CD-CB-40-
70
DHCP abilitato. . . . . . . . . . . . : No
Indirizzo IP. . . . . . . . . . . . . : 172.16.199.130
Subnet mask . . . . . . . . . . . . . : 255.255.255.0
Gateway predefinito . . . . . . . . . : 172.16.199.100
Server DNS . . . . . . . . . . . . . : 172.16.199.127
Server WINS primario . . . . . . . . : 172.16.199.127
Non so se hai visto, ma sul server Windows 2003 nel suffisso DNS
primario e come DNS primario di ricerca hai uno strano XX.local che non
corrisponde al nome di dominio Active Directory. Devi modificare queste
cose (il primo nelle proprietà avanzate nel tab Identificazione di
reted, anzi non mettere nulla e lascia il check su cambia suffisso DNS
quando cambia eccetera; il secondo parametro nelle proprietà avanzate
DNS nella configurazione TCP/IP, anzi eventualmente pulisci tutto).

Ciao
Memmo
Clayshin
2003-11-06 11:48:10 UTC
Permalink
Credo che le anomalie sui suffissi dipendano da miei tentativi dettati dalla
disperazione, cmq ora pulisco tutto e ti faccio sapere.
Post by Memmo
Post by a***@discussions.microsoft.com
Ecco a voi
***********************************************************
****************
Windows 2003
Configurazione IP di Windows
Nome host . . . . . . . . . . . . . . : XXXXXXXSVR01
GruppoXXXXXX.local
Tipo nodo . . . . . . . . . . . . . . : Ibrido
Routing IP abilitato. . . . . . . . . : No
Proxy WINS abilitato . . . . . . . . : No
GruppoXXXXXX.local
Descrizione . . . . . . . . . . . . . : Compaq NC7760
Gigabit Server Adapter
Indirizzo fisico. . . . . . . . . . . : 00-0B-CD-CB-40-
70
DHCP abilitato. . . . . . . . . . . . : No
Indirizzo IP. . . . . . . . . . . . . : 172.16.199.130
Subnet mask . . . . . . . . . . . . . : 255.255.255.0
Gateway predefinito . . . . . . . . . : 172.16.199.100
Server DNS . . . . . . . . . . . . . : 172.16.199.127
Server WINS primario . . . . . . . . : 172.16.199.127
Non so se hai visto, ma sul server Windows 2003 nel suffisso DNS
primario e come DNS primario di ricerca hai uno strano XX.local che non
corrisponde al nome di dominio Active Directory. Devi modificare queste
cose (il primo nelle proprietà avanzate nel tab Identificazione di
reted, anzi non mettere nulla e lascia il check su cambia suffisso DNS
quando cambia eccetera; il secondo parametro nelle proprietà avanzate
DNS nella configurazione TCP/IP, anzi eventualmente pulisci tutto).
Ciao
Memmo
Clayshin
2003-11-06 11:58:31 UTC
Permalink
Confermo ho pulito il tutto ma niente.
Cmq l'errore certamente sta nel fatto che il 2003 fà una query x il seg.
record svr:

_ldap._tcp.dc._<dominio>.com

che effetivamente sul dns non c'è e che dovrebbe essere creato da AD insieme
ad altri record (pure mancanti).

C'è un modo di farglieli ricreare oppure inserirli a manina ?
Ho provato a rifare le zone ma nisba.
Post by Clayshin
Credo che le anomalie sui suffissi dipendano da miei tentativi dettati dalla
disperazione, cmq ora pulisco tutto e ti faccio sapere.
Post by Memmo
Post by a***@discussions.microsoft.com
Ecco a voi
***********************************************************
****************
Windows 2003
Configurazione IP di Windows
Nome host . . . . . . . . . . . . . . : XXXXXXXSVR01
GruppoXXXXXX.local
Tipo nodo . . . . . . . . . . . . . . : Ibrido
Routing IP abilitato. . . . . . . . . : No
Proxy WINS abilitato . . . . . . . . : No
GruppoXXXXXX.local
Descrizione . . . . . . . . . . . . . : Compaq NC7760
Gigabit Server Adapter
Indirizzo fisico. . . . . . . . . . . : 00-0B-CD-CB-40-
70
DHCP abilitato. . . . . . . . . . . . : No
Indirizzo IP. . . . . . . . . . . . . : 172.16.199.130
Subnet mask . . . . . . . . . . . . . : 255.255.255.0
Gateway predefinito . . . . . . . . . : 172.16.199.100
Server DNS . . . . . . . . . . . . . : 172.16.199.127
Server WINS primario . . . . . . . . : 172.16.199.127
Non so se hai visto, ma sul server Windows 2003 nel suffisso DNS
primario e come DNS primario di ricerca hai uno strano XX.local che non
corrisponde al nome di dominio Active Directory. Devi modificare queste
cose (il primo nelle proprietà avanzate nel tab Identificazione di
reted, anzi non mettere nulla e lascia il check su cambia suffisso DNS
quando cambia eccetera; il secondo parametro nelle proprietà avanzate
DNS nella configurazione TCP/IP, anzi eventualmente pulisci tutto).
Ciao
Memmo
Andrea Gallazzi [MVP]
2003-11-06 14:35:50 UTC
Permalink
Post by Clayshin
C'è un modo di farglieli ricreare oppure inserirli a manina ?
Ho provato a rifare le zone ma nisba.
http://www.microsoft.com/technet/treeview/default.asp?url=/technet/prodtechnol/AD/windows2000/deploy/prodspecs/dnsreq.asp

Ciao!
--
Andrea Gallazzi
Microsoft Most Valuable Professional (TCP/IP, Windows 2K Server)
http://mvp.support.microsoft.com/
http://support.microsoft.com/newsgroups
http://www.microsoft.com/italy/technet/
*** Guida per microsoft.public.it.winserver ***
http://www.krisopea.it/mvp
Clayshin
2003-11-06 17:09:00 UTC
Permalink
Grazie ,
ho inserito i record a manina e tutto è andato liscio, anche se vorrei
sapere come mai i record interessati non venivano creati da AD.
Grazie a tutti dell'interessamento.
Post by Andrea Gallazzi [MVP]
Post by Clayshin
C'è un modo di farglieli ricreare oppure inserirli a manina ?
Ho provato a rifare le zone ma nisba.
http://www.microsoft.com/technet/treeview/default.asp?url=/technet/prodtechnol/AD/windows2000/deploy/prodspecs/dnsreq.asp
Post by Andrea Gallazzi [MVP]
Ciao!
--
Andrea Gallazzi
Microsoft Most Valuable Professional (TCP/IP, Windows 2K Server)
http://mvp.support.microsoft.com/
http://support.microsoft.com/newsgroups
http://www.microsoft.com/italy/technet/
*** Guida per microsoft.public.it.winserver ***
http://www.krisopea.it/mvp
Andrea Gallazzi [MVP]
2003-11-07 09:36:41 UTC
Permalink
Non so che dirti, avrebbero dovuto esserci...
Magari qualche sincronizzazione mancata, sempre che tu abbia avuto più
DNS...
--
Andrea Gallazzi
Microsoft Most Valuable Professional (TCP/IP, Windows 2K Server)
http://mvp.support.microsoft.com/
http://support.microsoft.com/newsgroups
http://www.microsoft.com/italy/technet/
*** Guida per microsoft.public.it.winserver ***
http://www.krisopea.it/mvp
G.
2003-11-06 08:03:04 UTC
Permalink
Ciao,
ho avuto un problema analogo.
Dopo essere diventato scemo ho trovato empiricamente una semplice soluzione:
* Ho disabilitato il DNS sul DC
* Ho installato il DNS nuovo nuovo sul W2K3
* ho fatto le varie modifiche di puntamento del DNS sia sul DC che sul W2K3
* ho rilanciato l'installazione di AD
* come per magia tutto a funzionato.

A me interessava poi mantenere il DNS sul W2K3 quindi mi sono fermato li....
Ciao

G.t.S
Post by ***@hotmail.com
Un saluto a tutti
sto cercando di implementare un server con W2003 in un
dominio esistente (W2K) ma quando specifico il dominio che
"Impossibile contattare un controller di dominio Active
directory per il dominio ******.com"
Ho provato ad eseguire un dcdiag sul DC (W2K) con il
[cut]
Continua a leggere su narkive:
Loading...