Discussione:
Di nuovo replica file
(troppo vecchio per rispondere)
Omar Gerosa
2007-11-28 11:29:02 UTC
Permalink
Ciao Ragazzi. Vedo che ancora nessuno mi ha risposto.- E' un po' urgente,
qualcuno sa darmi un info? Riporto il testo integrale di ieri:

Ho un problema in una rete così strutturata: possiedo un server impostato
come PDC (windows 2003 server sbs) e nella stessa rete una altro server di
backup con Windows 2003 server che è logato sotto lo stesso dominio.
I 2 server utilizzano lo stesso nome utente "Administrator" e la stessa
password.
Vorrei che tutti i dati, con un'operazione automatica, ogni notte fossero
copiati sul server di backup, così in caso di fermo del server principale lo
Studio continuerebbe a lavorare. Il server PDC principale (l'SBS) alle 21,30
si riavvia automaticamente e alle 23 parte il backup su nastro con Veritas
che termina alle 5.
L'altro server di backup si riavvia automaticamente alle 4 e alle 5,30
dovrebbe iniziare il trasferimento dei file.
Qui parte il mio problema: con un semplicissimo file batch "buttato" dentro
le operazioni pianificate questo non parte e mi restituisce l'errore 0x4
(???). La stessa cosa la faccio di sabato ma la copia avviene in locale dal
server SBS ma su un hdd esterno e questo processo parte regolarmente.
Ho provato anche con uno iomega Automatik backup ma non parte e il log è
vuoto!!!
Ho provato a lanciare queste operazioni sia dal server di backup che quindi
andava a richiamare i dati dal server sbs che viceversa e idem con iomega.
Sembra che dopo il riavvio qualcosa non funzioni perchè se lancio le
procedure manualmente partono e terminano. D'altro canto mi spiacerebbe non
far riavviare il server la notte.
Non so più cosa provare e il cliente comincia ad innervosirsi. Qualcuno può
aiutarmi? Grazie in anticipo. Omar.
Edoardo Benussi [MVP]
2007-11-28 13:34:23 UTC
Permalink
Post by Omar Gerosa
Ciao Ragazzi. Vedo che ancora nessuno mi ha risposto.- E' un po'
urgente, qualcuno sa darmi un info?
il fatto che sia urgente non obbliga nessuno a darti una risposta,
altrimenti puoi rivolgerti al servizio clienti microsoft numero 02.70398398
Post by Omar Gerosa
Riporto il testo integrale di
Ho un problema in una rete così strutturata: possiedo un server
impostato come PDC (windows 2003 server sbs)
da win2k non esistono più pdc e bdc
Post by Omar Gerosa
e nella stessa rete una
altro server di backup con Windows 2003 server che è logato sotto lo
stesso dominio.
non esistono server di backup.
Post by Omar Gerosa
I 2 server utilizzano lo stesso nome utente "Administrator" e la
stessa password.
e vorrei ben vedere visto che sono due dc dello
stesso dominio.
Post by Omar Gerosa
Vorrei che tutti i dati, con un'operazione automatica, ogni notte
fossero copiati sul server di backup, così in caso di fermo del
server principale lo Studio continuerebbe a lavorare.
fai un batch con xcopy.
Post by Omar Gerosa
Il server PDC
principale (l'SBS) alle 21,30 si riavvia automaticamente e alle 23
parte il backup su nastro con Veritas che termina alle 5.
L'altro server di backup si riavvia automaticamente alle 4 e alle 5,30
dovrebbe iniziare il trasferimento dei file.
Qui parte il mio problema: con un semplicissimo file batch "buttato"
dentro le operazioni pianificate questo non parte e mi restituisce
l'errore 0x4 (???).
con quale account è schedulato ?
l'account ha accesso alle shares del dc aggiuntivo ?
Post by Omar Gerosa
La stessa cosa la faccio di sabato ma la copia
avviene in locale dal server SBS ma su un hdd esterno e questo
processo parte regolarmente.
Ho provato anche con uno iomega Automatik backup ma non parte e il
log è vuoto!!!
Ho provato a lanciare queste operazioni sia dal server di backup che
quindi andava a richiamare i dati dal server sbs che viceversa e idem
con iomega. Sembra che dopo il riavvio qualcosa non funzioni perchè
se lancio le procedure manualmente partono e terminano. D'altro canto
mi spiacerebbe non far riavviare il server la notte.
Non so più cosa provare e il cliente comincia ad innervosirsi.
Qualcuno può aiutarmi? Grazie in anticipo. Omar.
per quale motivo fai riavviare i domain controllers ?
--
Edoardo Benussi - ***@mvps.org
Microsoft® MVP - Windows Server
http://mvp.support.microsoft.com
Omar Gerosa
2007-11-28 14:11:01 UTC
Permalink
Post by Edoardo Benussi [MVP]
Post by Omar Gerosa
Ciao Ragazzi. Vedo che ancora nessuno mi ha risposto.- E' un po'
urgente, qualcuno sa darmi un info?
il fatto che sia urgente non obbliga nessuno a darti una risposta,
altrimenti puoi rivolgerti al servizio clienti microsoft numero 02.70398398
grazie per la "cortese" risposta. questo lo so anch'io. ne volevo
approfittare dato oggi ero dal cliente con il problema
Post by Edoardo Benussi [MVP]
Post by Omar Gerosa
Riporto il testo integrale di
Ho un problema in una rete così strutturata: possiedo un server
impostato come PDC (windows 2003 server sbs)
da win2k non esistono più pdc e bdc
lo so. era per farvi capire le differenze tra i 2 server che uso.
Post by Edoardo Benussi [MVP]
Post by Omar Gerosa
e nella stessa rete una
altro server di backup con Windows 2003 server che è logato sotto lo
stesso dominio.
non esistono server di backup.
è il nome che ho usato i per distinguere i 2 server
Post by Edoardo Benussi [MVP]
Post by Omar Gerosa
I 2 server utilizzano lo stesso nome utente "Administrator" e la
stessa password.
e vorrei ben vedere visto che sono due dc dello
stesso dominio.
anche questo è esplicativo
Post by Edoardo Benussi [MVP]
Post by Omar Gerosa
Vorrei che tutti i dati, con un'operazione automatica, ogni notte
fossero copiati sul server di backup, così in caso di fermo del
server principale lo Studio continuerebbe a lavorare.
fai un batch con xcopy.
se leggi sotto tutto di un fiato vedi che l'ho già fatto
Post by Edoardo Benussi [MVP]
Post by Omar Gerosa
Il server PDC
principale (l'SBS) alle 21,30 si riavvia automaticamente e alle 23
parte il backup su nastro con Veritas che termina alle 5.
L'altro server di backup si riavvia automaticamente alle 4 e alle 5,30
dovrebbe iniziare il trasferimento dei file.
Qui parte il mio problema: con un semplicissimo file batch "buttato"
dentro le operazioni pianificate questo non parte e mi restituisce
l'errore 0x4 (???).
con quale account è schedulato ?
l'account ha accesso alle shares del dc aggiuntivo ?
prima domanda: con administrator e la password che utilizza per accedere
seconda domanda: si, certo, altrimenti finisce il gioco
Post by Edoardo Benussi [MVP]
Post by Omar Gerosa
La stessa cosa la faccio di sabato ma la copia
avviene in locale dal server SBS ma su un hdd esterno e questo
processo parte regolarmente.
Ho provato anche con uno iomega Automatik backup ma non parte e il
log è vuoto!!!
Ho provato a lanciare queste operazioni sia dal server di backup che
quindi andava a richiamare i dati dal server sbs che viceversa e idem
con iomega. Sembra che dopo il riavvio qualcosa non funzioni perchè
se lancio le procedure manualmente partono e terminano. D'altro canto
mi spiacerebbe non far riavviare il server la notte.
Non so più cosa provare e il cliente comincia ad innervosirsi.
Qualcuno può aiutarmi? Grazie in anticipo. Omar.
per quale motivo fai riavviare i domain controllers ?
per 1000 motivi che non sto a spiegare (perchè, non lo fate mai???? Prima di
fare i backup e per liberare la memoria del server? Conosco un sacco di
tecnici che lo fanno senza problemi.
Vabbè ho capito, non hai voglia di rispondermi.
Se rileggi ciò che hai scritto poi fammi sapere perchè devi rispondere in
tono così maleducato. Io sono stato educato nella mia esposizione.
Comunque grazie se mi vorrai rispondere.
Post by Edoardo Benussi [MVP]
--
Microsoft® MVP - Windows Server
http://mvp.support.microsoft.com
Edoardo Benussi [MVP]
2007-11-28 14:26:01 UTC
Permalink
Omar Gerosa <***@discussions.microsoft.com> wrote in message,
8EAC48D9-62B0-4A51-8EDD-***@microsoft.com
[cut]
Post by Omar Gerosa
per 1000 motivi che non sto a spiegare (perchè, non lo fate mai????
Prima di fare i backup e per liberare la memoria del server? Conosco
un sacco di tecnici che lo fanno senza problemi.
Vabbè ho capito, non hai voglia di rispondermi.
Se rileggi ciò che hai scritto poi fammi sapere perchè devi
rispondere in tono così maleducato. Io sono stato educato nella mia
esposizione.
prima ti spiego il motivo dell'acidità della mia risposta.
il punto è che "digerisco" difficilmente l'utilizzo
del termine "urgente" nel newsgroup dove ci sono
persone che tentano di aiutarne altre in maniera
del tutto gratuita, se un'aiuto è gratuito non
può essere richiesto "urgente", altrimenti fai andare me
dal tuo cliente e i soldini me li prendo io.
ok ?
Post by Omar Gerosa
Comunque grazie se mi vorrai rispondere.
dopo essermi sfogato ti rispondo in tutti i casi:

1) spegnimento dei servers: la mia filosofia è
che più vengono spenti e riaccesi e più si rovinano,
i servers vanno spenti solo quando gli aggiornamenti
richiedono il reboot o eventualmente se qualche processo
o servizio "si pianta".
in tutti gli altri casi più li lasci accesi meglio è.

2) cause possibili di mancata esecuzione del backup schedulato:
poichè il fenomeno si verifica solo quando parte il backup schedulato
dopo un reboot dovresti provare a riavviare uno dei due server
e verificare in quanto tempo vengono tirati su i servizi
essenziali per poter usare la rete da parte di quel server.
hai detto che il server 2 si spegne alle 4,
quanto ci mette a riavviarsi ?
tutti i servizi ad avviamento automatico si riavviano correttamente
o ne trovi qualcuno stoppato ?
ci sono errori nel registro eventi del server 2 ?
--
Edoardo Benussi - ***@mvps.org
Microsoft® MVP - Windows Server
http://mvp.support.microsoft.com
Omar Gerosa
2007-11-28 14:47:01 UTC
Permalink
Post by Edoardo Benussi [MVP]
[cut]
Post by Omar Gerosa
per 1000 motivi che non sto a spiegare (perchè, non lo fate mai????
Prima di fare i backup e per liberare la memoria del server? Conosco
un sacco di tecnici che lo fanno senza problemi.
Vabbè ho capito, non hai voglia di rispondermi.
Se rileggi ciò che hai scritto poi fammi sapere perchè devi
rispondere in tono così maleducato. Io sono stato educato nella mia
esposizione.
prima ti spiego il motivo dell'acidità della mia risposta.
il punto è che "digerisco" difficilmente l'utilizzo
del termine "urgente" nel newsgroup dove ci sono
persone che tentano di aiutarne altre in maniera
del tutto gratuita, se un'aiuto è gratuito non
può essere richiesto "urgente", altrimenti fai andare me
dal tuo cliente e i soldini me li prendo io.
ok ?
su questo hai ragione. fortunatamente non ho sempre bisogno dell'aiuto
vostro perchè va sempre tutto bene e in questo caso non sapevo di questa
cosa. inoltre ero abituato bene perchè di solito le risposte arrivavano in
mezz'ora massimo 1 ora. l'importante è capirsi e vedrai che non lo farò più.
Post by Edoardo Benussi [MVP]
Post by Omar Gerosa
Comunque grazie se mi vorrai rispondere.
1) spegnimento dei servers: la mia filosofia è
che più vengono spenti e riaccesi e più si rovinano,
i servers vanno spenti solo quando gli aggiornamenti
richiedono il reboot o eventualmente se qualche processo
o servizio "si pianta".
in tutti gli altri casi più li lasci accesi meglio è.
su questo hai ragione e sono d'accordo con te. qui capitava talvolta che non
mi copiasse file perchè restavano bloccati, dopo il riavvio era meglio.
Post by Edoardo Benussi [MVP]
poichè il fenomeno si verifica solo quando parte il backup schedulato
dopo un reboot dovresti provare a riavviare uno dei due server
e verificare in quanto tempo vengono tirati su i servizi
essenziali per poter usare la rete da parte di quel server.
circa 10/15 minuti per il riavvio totale
Post by Edoardo Benussi [MVP]
hai detto che il server 2 si spegne alle 4
quanto ci mette a riavviarsi ?
esatto. è un server piccolo di appoggio e ci mette circa 6/7 minuti
Post by Edoardo Benussi [MVP]
tutti i servizi ad avviamento automatico si riavviano correttamente
o ne trovi qualcuno stoppato ?
ci sono errori nel registro eventi del server 2 ?
il server 2 va bene.
invece il server 1 ha qualche problema con il servizio remote access e dhcp
server (stopped) dopo che ho fatto una modifica su Symantec Backup (veritas).
il server 2 va bene.
Ho pensato magari che il riavvio potesse non ricollegare le unità.
Adesso ho fatto una modifica al registro dei 2 server in modo che abbiano il
logon automatico con nome utente e password e che il server 2 venga riavviato
prima del server 1 e non dopo come avviene adesso.

Ciao!!!
Post by Edoardo Benussi [MVP]
--
Microsoft® MVP - Windows Server
http://mvp.support.microsoft.com
Edoardo Benussi [MVP]
2007-11-28 16:07:03 UTC
Permalink
Post by Omar Gerosa
il server 2 va bene.
invece il server 1 ha qualche problema con il servizio remote access
e dhcp server (stopped) dopo che ho fatto una modifica su Symantec
Backup (veritas). il server 2 va bene.
posta gli errori.
Post by Omar Gerosa
Ho pensato magari che il riavvio potesse non ricollegare le unità.
Adesso ho fatto una modifica al registro dei 2 server in modo che
abbiano il logon automatico con nome utente e password e che il
server 2 venga riavviato prima del server 1 e non dopo come avviene
adesso.
le unità su cui vengono fatti i backup sono mappate ?
--
Edoardo Benussi - ***@mvps.org
Microsoft® MVP - Windows Server
http://mvp.support.microsoft.com
Omar Gerosa
2007-11-28 16:36:02 UTC
Permalink
Post by Edoardo Benussi [MVP]
Post by Omar Gerosa
il server 2 va bene.
invece il server 1 ha qualche problema con il servizio remote access
e dhcp server (stopped) dopo che ho fatto una modifica su Symantec
Backup (veritas). il server 2 va bene.
posta gli errori.
niente di particolare, dice che i servizi elencati sono stopped e poi la
solita frase di routine
Post by Edoardo Benussi [MVP]
Post by Omar Gerosa
Ho pensato magari che il riavvio potesse non ricollegare le unità.
Adesso ho fatto una modifica al registro dei 2 server in modo che
abbiano il logon automatico con nome utente e password e che il
server 2 venga riavviato prima del server 1 e non dopo come avviene
adesso.
le unità su cui vengono fatti i backup sono mappate ?
certo, è mappata come Z
Post by Edoardo Benussi [MVP]
--
Microsoft® MVP - Windows Server
http://mvp.support.microsoft.com
Edoardo Benussi [MVP]
2007-11-29 13:11:53 UTC
Permalink
Post by Omar Gerosa
certo, è mappata come Z
invece di mappare l'unità ti spiace provare
a mettere
\\[tuoserver]\[tuacartellacondivisa]

e verificare se così funziona ?

la mappatura funziona solo con l'account loggato
ma quando tu riavvi la macchina non c'è alcun
account loggato.
--
Edoardo Benussi - ***@mvps.org
Microsoft® MVP - Windows Server
http://mvp.support.microsoft.com
Mario Z
2007-11-28 14:35:53 UTC
Permalink
Post by Omar Gerosa
Ciao Ragazzi. Vedo che ancora nessuno mi ha risposto.- E' un po' urgente,
potevi evitare di quotare nuovamente.
comunque,

guarda questo link e dicci qual'è errore esatto
http://support.microsoft.com/kb/308558

e poi non capisco il perchè tu voglia riavviare il server ?

Mario Z.
Omar Gerosa
2007-11-28 15:46:00 UTC
Permalink
Post by Mario Z
Post by Omar Gerosa
Ciao Ragazzi. Vedo che ancora nessuno mi ha risposto.- E' un po' urgente,
potevi evitare di quotare nuovamente.
comunque,
guarda questo link e dicci qual'è errore esatto
http://support.microsoft.com/kb/308558
0x4
Post by Mario Z
e poi non capisco il perchè tu voglia riavviare il server ?
ho dei file bloccati di cui non fa il backup e il riavvio li sblocca
Post by Mario Z
Mario Z.
Mario Z
2007-11-29 09:05:57 UTC
Permalink
Post by Mario Z
guarda questo link e dicci qual'è errore esatto
http://support.microsoft.com/kb/308558
0x4
permettimi la domanda, ma il link lo hai letto ?
il file di log Schedlgu.txt che errore riporta solo 0X4 ?
potresti abilitare tutti gli audit failure per vedere che errore viene
registrato negli eventi di sistema.

Mario Z
Omar Gerosa
2007-11-29 14:43:04 UTC
Permalink
Post by Mario Z
Post by Mario Z
guarda questo link e dicci qual'è errore esatto
http://support.microsoft.com/kb/308558
0x4
permettimi la domanda, ma il link lo hai letto ?
il file di log Schedlgu.txt che errore riporta solo 0X4 ?
potresti abilitare tutti gli audit failure per vedere che errore viene
registrato negli eventi di sistema.
Mario Z
Grazie a tutti ma ho risolto.
Mi è bastato inserire nel registro di windows il logon automatico, cioè come
se ci fosse qualcuno davanti che fa CTRL+ALT+CANC e inserisca User ID e
Password. Così funziona e la copia di file con un banale batch parte.
Grazie comunque a tutti voi.
Omar

Continua a leggere su narkive:
Loading...