Discussione:
problema pagine ASP
(troppo vecchio per rispondere)
Nitro
2005-03-16 11:05:04 UTC
Permalink
ho un server win2000 sp3 sul quale è installato IIS 5.0
Quando eseguo pagine .asp, invece di essere "processate", compare nel
browser il listato del codice ASP
E' normale questa situazione ?

Grazie in anticipo

Nitro
stefanino
2005-03-16 11:18:22 UTC
Permalink
sei sicuro di aver messo i tag asp
<%
....
codice
....
%>

e di aver chiamato la pagina tuapagina.asp???


---------------------------------------
SysAdmin.it
...your Skill is your Power
www.sysadmin.it
---------------------------------------
Post by Nitro
ho un server win2000 sp3 sul quale è installato IIS 5.0
Quando eseguo pagine .asp, invece di essere "processate", compare nel
browser il listato del codice ASP
E' normale questa situazione ?
Grazie in anticipo
Nitro
Nitro
2005-03-16 11:31:52 UTC
Permalink
Post by stefanino
sei sicuro di aver messo i tag asp
<%
....
codice
....
%>
e di aver chiamato la pagina tuapagina.asp???
Premetto che non ho scritto io il codice e non conosco il linguaggio asp

Ci sono i tag e il file ha estensione .asp
Riporto le prime righe :

<%@LANGUAGE=VBSCRIPT%>
<% OPTION EXPLICIT %>
<!--#INCLUDE FILE = "../../Include/DB_Connect.asp"-->
<!--#INCLUDE FILE = "../../Include/No_Cache.asp"-->
<!--#INCLUDE FILE = "../../Include/Function.asp"-->


La cosa strana è che questa anomalia succede solo su alcune pagine ASP (non
so discriminare la differenza)
Nel caso specifico se una delle pagine che produce l'anomalia viene
richiamata da un bottone di un'altra pagina asp, allora funziona


Riporto alcune righe del bottone :

<table width="782" border="0" align="center" cellspacing="0"
bgcolor="#424D64" id="table1">
<tr>
<td colspan="4" bgcolor="#FFFFFF"><p align="center" class="style5">.::
xxxxxxxxxxxxx::.</p>
<p align="center" class="style4">xxxxxxxxxxxxxxxxxxxxxxxxxxxxx:
</p></td>
</tr>
<tr>
<td colspan="4"><div align="left"><font face="Verdana" size="2"
color="#FFFFFF"><b>.:: xxxxxxxxxxxxxxx</b></font></div></td>
</tr>
<tr>
<td width="27%" bgcolor="#FFFFFF"><span class="style4">Bottone
</span></td>
<td width="22%" bgcolor="#FFFFFF"><input name="Submit" type="submit"
onClick="MM_goToURL('parent','http://percorso_pagina.asp?mod=0');return
document.MM_returnValue" value="- apri -"></td>


Non so se le info che ho messo sono utili

Nitro
Mitch
2005-03-16 11:35:25 UTC
Permalink
Post by Nitro
Post by stefanino
sei sicuro di aver messo i tag asp
<%
....
codice
....
%>
e di aver chiamato la pagina tuapagina.asp???
Premetto che non ho scritto io il codice e non conosco il linguaggio asp
Ci sono i tag e il file ha estensione .asp
<% OPTION EXPLICIT %>
<!--#INCLUDE FILE = "../../Include/DB_Connect.asp"-->
<!--#INCLUDE FILE = "../../Include/No_Cache.asp"-->
<!--#INCLUDE FILE = "../../Include/Function.asp"-->
La cosa strana è che questa anomalia succede solo su alcune pagine ASP (non
so discriminare la differenza)
Nel caso specifico se una delle pagine che produce l'anomalia viene
richiamata da un bottone di un'altra pagina asp, allora funziona
<table width="782" border="0" align="center" cellspacing="0"
bgcolor="#424D64" id="table1">
<tr>
<td colspan="4" bgcolor="#FFFFFF"><p align="center"
xxxxxxxxxxxxx::.</p>
</p></td>
</tr>
<tr>
<td colspan="4"><div align="left"><font face="Verdana" size="2"
color="#FFFFFF"><b>.:: xxxxxxxxxxxxxxx</b></font></div></td>
</tr>
<tr>
<td width="27%" bgcolor="#FFFFFF"><span class="style4">Bottone
</span></td>
<td width="22%" bgcolor="#FFFFFF"><input name="Submit" type="submit"
onClick="MM_goToURL('parent','http://percorso_pagina.asp?mod=0');return
document.MM_returnValue" value="- apri -"></td>
Non so se le info che ho messo sono utili
ma questo lo hai messo tu o è veramente nella pagina?
'http://percorso_pagina.asp?mod=0'

mi sembra al quanto strano,
sei sicuro che le pagine che vengono chiamate siano sotto IIS e contengano i
tag corretti?
Post by Nitro
Nitro
Mitch
Nitro
2005-03-16 11:51:06 UTC
Permalink
l'ho messo io, in ogni caso potrebbe essere un percorso di pagina ASP
qualunque
Le pagine sono sotto wwwroot\sottocartella di IIS e se vengono chiamate dal
bottone funzionano correttamente
Se invece tento di aprirle con un doppio click, viene mostrato nel browser
il listato del codice asp
Ho notato che succede indipendentemente dalla versione di IE e anche se
faccio la prova direttamente sul server IIS

Nitro
Post by Mitch
ma questo lo hai messo tu o è veramente nella pagina?
'http://percorso_pagina.asp?mod=0'
mi sembra al quanto strano,
sei sicuro che le pagine che vengono chiamate siano sotto IIS e contengano i
tag corretti?
Nitro
Mitch
Edoardo Benussi [MVP]
2005-03-16 11:56:23 UTC
Permalink
Post by Nitro
l'ho messo io, in ogni caso potrebbe essere un percorso di pagina ASP
qualunque
Le pagine sono sotto wwwroot\sottocartella di IIS e se vengono
chiamate dal bottone funzionano correttamente
Se invece tento di aprirle con un doppio click, viene mostrato nel
browser il listato del codice asp
[cut]

aprirle con doppio clic da dove ?
da esplora risorse ?
--
Edoardo Benussi - ***@mvps.org
Microsoft® MVP - Windows Server
http://mvp.support.microsoft.com
http://italy.mvps.org
Nitro
2005-03-17 15:31:46 UTC
Permalink
si, le ho aperte da esplora risorse.
Come dovrei testarle ?

Ciao
Nitro
Post by Edoardo Benussi [MVP]
[cut]
aprirle con doppio clic da dove ?
da esplora risorse ?
--
Microsoft® MVP - Windows Server
http://mvp.support.microsoft.com
http://italy.mvps.org
Edoardo Benussi [MVP]
2005-03-17 16:00:24 UTC
Permalink
Post by Nitro
si, le ho aperte da esplora risorse.
Come dovrei testarle ?
[cut]

poichè le pagine asp
prevedono l'esecuzione di codice lato server
per verificare se funzionano devi
scrivere nella barra degli indirizzi di internet explorer
o di altro browser
http://[ipdeltuowebserver]/[eventualepath]/[nomedellatuapaginaasp]

altrimenti non potrai mai vederle in esecuzione
proprio perchè il codice viene eseguito
dal web server che ritorna al client solo html.
ciao.
--
Edoardo Benussi - ***@mvps.org
Microsoft® MVP - Windows Server
http://mvp.support.microsoft.com
http://italy.mvps.org
Nitro
2005-03-17 16:50:35 UTC
Permalink
adesso ci sono !
Grazie 1000 !!

bye
Nitro
Post by Edoardo Benussi [MVP]
poichè le pagine asp
prevedono l'esecuzione di codice lato server
per verificare se funzionano devi
scrivere nella barra degli indirizzi di internet explorer
o di altro browser
http://[ipdeltuowebserver]/[eventualepath]/[nomedellatuapaginaasp]
altrimenti non potrai mai vederle in esecuzione
proprio perchè il codice viene eseguito
dal web server che ritorna al client solo html.
ciao.
--
Microsoft® MVP - Windows Server
http://mvp.support.microsoft.com
http://italy.mvps.org
Mitch
2005-03-16 12:15:13 UTC
Permalink
Post by Nitro
l'ho messo io, in ogni caso potrebbe essere un percorso di pagina ASP
qualunque
Le pagine sono sotto wwwroot\sottocartella di IIS e se vengono chiamate dal
bottone funzionano correttamente
Se invece tento di aprirle con un doppio click, viene mostrato nel browser
il listato del codice asp
Ho notato che succede indipendentemente dalla versione di IE e anche se
faccio la prova direttamente sul server IIS
non funzionano cosi le pagine asp, non devi fare doppio click
e poi quella pagina potrebbe aver bisogno di altre informazioni,
querystring-session-application-request-cookie ecc.ecc.
le pagine asp vanno testare dal browser
Post by Nitro
Nitro
Post by Mitch
ma questo lo hai messo tu o è veramente nella pagina?
'http://percorso_pagina.asp?mod=0'
mi sembra al quanto strano,
sei sicuro che le pagine che vengono chiamate siano sotto IIS e
contengano
i
Post by Mitch
tag corretti?
Nitro
Mitch
Nitro
2005-03-17 15:32:56 UTC
Permalink
Post by Mitch
non funzionano cosi le pagine asp, non devi fare doppio click
e poi quella pagina potrebbe aver bisogno di altre informazioni,
querystring-session-application-request-cookie ecc.ecc.
le pagine asp vanno testare dal browser
come vanno testate nel browser ?

Ciao
Nitro
Mitch
2005-03-17 20:10:37 UTC
Permalink
Post by Nitro
Post by Mitch
non funzionano cosi le pagine asp, non devi fare doppio click
e poi quella pagina potrebbe aver bisogno di altre informazioni,
querystring-session-application-request-cookie ecc.ecc.
le pagine asp vanno testare dal browser
come vanno testate nel browser ?
sono arrivato tardi, cmq come ti ha detto già Edo
e per modificarle ti basta il notepad
Post by Nitro
Ciao
ciao
Post by Nitro
Nitro
Michele

Mrc
2005-03-16 12:55:37 UTC
Permalink
IIS è configurato per poter eseguire pagine ASP?
Post by Nitro
ho un server win2000 sp3 sul quale è installato IIS 5.0
Quando eseguo pagine .asp, invece di essere "processate", compare nel
browser il listato del codice ASP
E' normale questa situazione ?
Grazie in anticipo
Nitro
Mitch
2005-03-16 13:11:22 UTC
Permalink
Post by Mrc
IIS è configurato per poter eseguire pagine ASP?
direi proprio di si, altrimenti avrebbe avuto problemi su tutte le pagine
il suo penso sia un falso problema
cmq iis non deve avere delle particolari configurazioni per eseguire pagine
asp
una volta installato è già pronto, poi si puo configurarlo ulteriormente
Post by Mrc
Post by Nitro
ho un server win2000 sp3 sul quale è installato IIS 5.0
Quando eseguo pagine .asp, invece di essere "processate", compare nel
browser il listato del codice ASP
E' normale questa situazione ?
Grazie in anticipo
Nitro
Continua a leggere su narkive:
Loading...